Results 1 to 3 of 3

Thread: Ext.clone bug with firefox [firefox bug not expected by extjs]

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Jun 2008
    Vote Rating

    Exclamation Ext.clone bug with firefox [firefox bug not expected by extjs]

    Sorry for the previous bad bug report.

    Ext version tested:
    • Ext 4.0.7

    Browser versions tested against:
    • Firefox 10.0.2 (Unix)

    • With a kind of Extjs own created object (I tested it with a record), when
      Ext.clone executed
      var type =;
      The type of the record is and Ext.clone not clone the object and return the original item.
    • it is a Firefox bug: []

    Steps to reproduce the problem:
    • Create an Ext object ( I tested with and debug with

    The result that was expected:
    • [object Object]

    The result that occurs instead:
    • [xpconnect wrapped native prototype]

    Possible fix:

    var type =;

    Operating System:
    • Unix

    Rubn Burn Rodrigo.
    StackOps Developer.

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Gainesville, FL
    Vote Rating


    So you tried Ext.clone on a record?
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    Learn BBCode and use it!

    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2

    Think my support is good? Get more personalized support via a support subscription.

    Need more help with your app? Hire Sencha Services

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  3. #3
    Sencha User
    Join Date
    Jun 2008
    Vote Rating


    Quote Originally Posted by mitchellsimoens View Post
    So you tried Ext.clone on a record?
    I only tried, I needed to clone the data of an array of records without the references, but when I see the code of clone, I realized I need to copy the data, not clone it.

    Finally I use other method to "clone"(copy) the data of an array of records:

    PHP Code:
    * function to return a copy of the records without references
    *@param records[] array of records to copy
    *@return newData[] the array with the copy of the records
    copyRecords     :       function(records){
    newData   =  []
    newData[i]     =    {};
    newData[i][]    =    record.get(;

    But if you create a Model manually you can check the bug with the example.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts