Results 1 to 3 of 3

Thread: Hidden TabBar leaves empty space

  1. #1
    Sencha User
    Join Date
    Dec 2011
    Posts
    19

    Default Hidden TabBar leaves empty space

    I have TabBar added to application in my viewport. I also have login page on which I don't want to show the tabbar. I use the Ext.getCmp('TabBar').hide() to hide the tabbar. It is working since this docked item is not visible. However if I scroll my login page, I see that the content dissapear earlier than it should.
    tabbar_error.jpg

    I have also noticed, that the error is visible in dom tree:
    tabbar_error2.jpg

    I hope you can see in the above example, there is a #mainPanel that contains both #TabBar div, and another div #ext-gen1004 that containt the actual form.
    I think the problem is with the #ext-gen1004 div, it looks like Sencha is not refreshing the height of the element. I tried access this element and call doComponentLayout() on it, but I couldn't get it. Calling Ext.getCmp('ext-gen1004') just throws undefined error...
    After resizing window everything starts to work just fine.
    Can anybody help me on that one?
    Last edited by Marrbacca; 20 Mar 2012 at 10:37 AM. Reason: presentation fixes

  2. #2
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,451
    Answers
    3997

    Default

    Try executing doComponentLayout on the tab panel after you hide or show it. Does that help?
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Fullstack Engineer
    ________________
    Modus Create is based on the model of an open source team. We’re a remote, global team of experts in our field. To find out more about the work we do, head over to our website.

    Check out my GitHub:
    https://github.com/mitchellsimoens

  3. #3
    Sencha User
    Join Date
    Dec 2011
    Posts
    19

    Default

    Well, I do not have TabPanel . I use some extension TabBarMvc to resolve controller/action urls and I use simple panels. I tried to call doComponentLayout on the formPanel but it didn't work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •