I'm a Visual Basic .NET Desktop and Web developer and an iOS developer.

I've got a native iOS application that I am considering porting to a web application using Sencha Touch.

I write websites for ASP.NET and would like to continue using IIS as my web server.

I've not gotten very far in the "Getting Started" area of things, but I have gotten the SDK installed on my server and browsing to http://localhost/sencha-touch-2.0.0-gpl (using a desktop browser) will indeed show me the documentation site.

The thing is, trying to browse there from an iOS device (tried iPhone and iPad) shows just a blank page.

I also tried the "GS" starter application. Upon loading that app, I get the 3 dot indicator, but it simply scrolls forever. I never get beyond that point to the HTML content.

I have only just started looking into Sencha Touch this morning, and I have no prior experience with anything but HTML, ASP.NET and jQuery, so the syntax and structure of the code is still a little bit unknown to me. (It's a bit disheartening that the "Getting Started" project is failing for me.)

I see in index.html the following line:

<script id="microloader" type="text/javascript" src="sdk/microloader/development.js"></script>

Apparently, that's going to chain everything together so that it all just works, right?

I also see in "app.js" where all of the setup is supposed to actually occur.

What I don't yet see is how my page gets from development.js to app.js. In fact, it appears to me that it's NOT actually getting from point A to point B.

Can anybody help me out?

I'm sure this is a simply fix and a stupid noob question, so please be gentle.