Results 1 to 4 of 4

Thread: Flash tap events blocked

  1. #1
    Sencha User
    Join Date
    Mar 2012
    Posts
    6
    Vote Rating
    0
      0  

    Default Answered: Flash tap events blocked

    Hi, I am writing an app in which I have to use a flash player(jwplayer) to play videos (for android devices). So my problem is that when I add a flash object to dom, it does not respond to any click events. I have a feeling that Sencha Touch prevents them from firing, I just can't figure out where it happens and if there is a way to change this behavior.
    I've read the source of Ext.Component and Ext.AbstractComponent and could not find a way to do that. Any ideas?

    P.S.: I can't use Ext.Video(html5 video tag) as the video is streamed over rtmp.

    Thanks in advance!

  2. Try setting preventZoom to false in the viewport config (this will default to false in the next release)

    Code:
    Ext.application({
        viewport : {
            preventZooming : false
        }
    });

  3. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,556
    Answers
    3931
    Vote Rating
    1272
      0  

    Default

    Try setting preventZoom to false in the viewport config (this will default to false in the next release)

    Code:
    Ext.application({
        viewport : {
            preventZooming : false
        }
    });
    Last edited by mitchellsimoens; 11 Apr 2012 at 8:44 AM. Reason: preventZoom -> preventZooming
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  4. #3
    Sencha User
    Join Date
    Mar 2012
    Posts
    6
    Vote Rating
    0
      0  

    Default

    Thanks mitchellsimoens.
    It did the trick. Though the right property is preventZooming not preventZoom.

    viewport : { preventZoomimg : false }

  5. #4
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,556
    Answers
    3931
    Vote Rating
    1272
      0  

    Default

    Quote Originally Posted by vkryachko View Post
    Thanks mitchellsimoens.
    It did the trick. Though the right property is preventZooming not preventZoom.

    viewport : { preventZoomimg : false }
    My bad! Good catch!
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •