Results 1 to 3 of 3

Thread: Icons specified twice? (app.js and packager.json)

  1. #1
    Sencha User
    Join Date
    Feb 2012
    Posts
    44
    Answers
    1
    Vote Rating
    3
      0  

    Default Answered: Icons specified twice? (app.js and packager.json)

    Why are the app icons specified twice? Once in app.js:

    Code:
        icon: {
            57: 'resources/icons/Icon.png',
            72: 'resources/icons/Icon~ipad.png',
            114: 'resources/icons/Icon@2x.png',
            144: 'resources/icons/Icon~ipad@2x.png'
        },
    and then again the packager.json specifies an icon:

    Code:
        "iconName":"resources/icons/Icon.png",
    Which is used when & by what tools?

  2. The icon config in Ext.application would be used if you launched your web app in mobile safari and then added it to the homescreen, this config would state what icon to show there. The iconName in packager.json would be the icon for that native app.

  3. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,556
    Answers
    3932
    Vote Rating
    1272
      0  

    Default

    The icon config in Ext.application would be used if you launched your web app in mobile safari and then added it to the homescreen, this config would state what icon to show there. The iconName in packager.json would be the icon for that native app.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  4. #3
    Sencha Premium Member
    Join Date
    Oct 2011
    Posts
    64
    Answers
    3
    Vote Rating
    0
      0  

    Default

    I still get that strange behavior with these homescreen icons.
    For some reason they seem to show up properly for older iPhones and iPod Touches.
    For the new iPhone 4S and the new iPad they just wont show up properly. A little screenshot of the app will be displayed instead.

    Any hints why this could act like that?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •