Results 1 to 5 of 5

Thread: [RC3] tabs with iconCls with icons at 16px cut off?

  1. #1
    Sencha User slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,165
    Vote Rating
    253
      0  

    Default [RC3] tabs with iconCls with icons at 16px cut off?

    Is anyone seeing where in tabs with an iconCls with a 16x16 icon is cut off on the top? Laterally seems to be ok, but cuts the top row of pixels off.
    Seeing this in FF9 and IE8.

    Here's an icon to test with:
    http://www.iconarchive.com/show/fugue-icons-by-yusuke-kamiyamane/marker-icon.html

    I
    f you need screenshots or anything let me know.

  2. #2
    Sencha User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,062
    Vote Rating
    1391
      0  

    Default

    Have you inspected the DOM to see if the size is not set correctly?
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Frontend Engineer
    ________________
    Need any sort of Ext JS help? Modus Create is here to help!

    Check out my GitHub:
    https://github.com/mitchellsimoens

  3. #3
    Sencha User slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,165
    Vote Rating
    253
      0  

    Default

    The closest I'd say I've come to fixing it is changing
    .x-tab-icon from background-position: 0 -1px;
    to background-position: 0 0;

    and adding to .x-tab-icon margin-top: -1px;

    Tested in FF9.

  4. #4
    Ext JS Premium Member
    Join Date
    Dec 2009
    Posts
    65
    Vote Rating
    4
      0  

    Default

    I am seeing the same problem in every browser I've tried (IE, FF, Chrome, Safari, Opera). The 16x16 icon in the tab header gets cut off at the top. I think a similar problem was fixed in RC2 (EXTJSIV-5448) but apparently there's still an issue.

  5. #5
    Ext JS Premium Member Sébastien.Volle's Avatar
    Join Date
    Apr 2011
    Location
    Grenoble, France
    Posts
    70
    Vote Rating
    0
      0  

    Default

    Quote Originally Posted by slemmon View Post
    The closest I'd say I've come to fixing it is changing
    .x-tab-icon from background-position: 0 -1px;
    to background-position: 0 0;

    and adding to .x-tab-icon margin-top: -1px;

    Tested in FF9.
    This fix works also on Chrome, thanks.
    aka Seboss

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •