Results 1 to 3 of 3

Thread: Unable to Package in Sencha Architect 2.0 build 412 on both Vista and Ubuntu

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Apr 2012
    Vote Rating

    Default Unable to Package in Sencha Architect 2.0 build 412 on both Vista and Ubuntu

    Configuration on both machines is SA2.0 build 412, sencha-touch-2.0.1, and SenchaSDKTools-2.0.0-beta3

    On both vista and ubuntu I can from the sencha-touch-2.0.1 folder run

    sencha app create MyApp1 c:/senchaprojects/myapp1 (win)
    sencha app create MyApp1 /senchaprojects/myapp1 (ubuntu)
    This successfully creates myapp1 project with all the related files (sdk etc).
    I can then setup my webserver to point to the myapp1 folder, browser to the app, all works fine.

    I can also build the app for production successfully with

    c:\senchaprojects\myapp1\sencha app build production
    This is all good and proves the paths a to SDK's etc are all OK, in both environments.

    I now create myapp2 (just a simple navview) in SA2.0 located at c:/senchaprojects.

    Problem 1 -Package button is greyed
    On the Ubuntu machine
    When I select Deploy I get a dialog that says SDKTools v2 Installed:false and only the Copy button is clickable.
    The Package button is greyed.
    Many other users in the forum have this same problem but knowone from sencha has commented yet.

    If I just select Copy that works as expected and I can browse the app.

    However on the vista machine
    When I select Deploy I get dialog that says SDKTools v2 Installed:true and both Copy and Package
    buttons are clickable.
    If I just select Copy that works as expected and I can browse the app, as above.
    If I select Package the Package:packager.json dialog comes up, I accept the defaults and click Save and Package.

    Problem 2 -Error message
    A dialog is displayed with the following text
    31m[1m[WARN] The current working directory (C:\sencha\SenchaArchitect) is not a recognized Sencha SDK or application folder. Running in backwards compatible mode.[22m[39m Sencha Command v2.0.0 Beta 3 Copyright (c) 2012 Sencha Inc. usage: sencha COMMAND [ARGS] The available commands are: build build a JSB project create bootstrapdata     generate boostrap data create jsb     generate a minimal JSB project for an app create locale generate a template locale file from source create manifest     generate classes manifest package     package your Touch web app into a native bundle slice theme     slice a custom theme's images for IE See 'sencha help COMMAND' for more information on a specific command. [31m[1m[ERROR] The current working directory (C:\sencha\SenchaArchitect) is not a recognized Sencha SDK or application folder[22m[39m Error copying build/native/ to build//My Failed to package application
    In not sure why it should be looking in the SenchaArchitect directory, to my mind it should be the app directory, but I can't see where to change this.

    I then thought to try the manual build process that worked above for the sencha-touch-2.0.1 created app on a SA2.0 created app.

    When I try in both environments
    c:\senchaprojects\myapp2\sencha app build production
    Problem 3 -Error message
    I get the following
    "[ERROR] The current working (c:\senchaprojects\myapp2) is not a recognized Sencha SDK or application folder"
    Many other forum users have also reported this, with suggestions to do with creating a .senchasdk file
    in various locations, none of this suggests have worked for me.

    I hope this is enough information to solve the problems.

    SA2.0 looks great so far, but these are show stoppers for me.
    Last edited by rgratwick; 2 May 2012 at 5:37 PM. Reason: clarification

  2. #2
    Sencha User
    Join Date
    Sep 2011
    Vote Rating


    Hi guys, we are dealing with the same kind of troubles. Is this a bug or is just that the sencha command line doesn't work together with architect?
    The app structure that are created from architect and the command line are totally different.

    It would be great if we could use the command line functionality with projects on the architect, but we haven't succeed on that yet.

    Do you have any tips, suggestions or a clarification about this issues.

  3. #3
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Vote Rating


    In windows, the packager must run from within the projects working directory. We've updated the deployment/packing script to resolve this issue and it will be fixed in the next auto update.
    Aaron Conran

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts