Results 1 to 3 of 3

Thread: Any Vertical Tab Panel for Ext 4.1?

  1. #1
    Ext JS Premium Member
    Join Date
    Jun 2010
    Posts
    100
    Vote Rating
    18
      0  

    Default Any Vertical Tab Panel for Ext 4.1?

    Is there any Vertical Tab Panel that works with Ext 4.1?

    I couldn't find any .

    Also strange that this functionality is not simply in the standard Ext 4.1, since the Ext.tab.Panel seems to support 'tabPosition': "top" and "bottom" but not "left" and "right" .

    Thanks in advance.

  2. #2
    Sencha User SunboX's Avatar
    Join Date
    Mar 2010
    Posts
    238
    Vote Rating
    28
      0  

    Default

    You could do something like this:

    PHP Code:
    Ext.define('Ux.tab.VerticalPanel', {
        
    extend'Ext.tab.Panel',
        
    alias'widget.vertical-tabpanel',
        
        
    tabBar: {
            
    width140,
            
    minTabWidth130,
            
    maxTabWidth130,
            
    orientation'vertical'
        
    },
        
    tabPosition'right',
        
        
    plaintrue
    }); 
    but you have to style it your own. :/ Sad, that Ext 4.1 doesnt completely support vertical tabs.

    greetings Sunny

  3. #3
    Ext JS Premium Member
    Join Date
    Jun 2010
    Posts
    100
    Vote Rating
    18
      0  

    Default

    Quote Originally Posted by SunboX View Post
    You could do something like this:

    PHP Code:
    Ext.define('Ux.tab.VerticalPanel', {
        
    extend'Ext.tab.Panel',
        
    alias'widget.vertical-tabpanel',
        
        
    tabBar: {
            
    width140,
            
    minTabWidth130,
            
    maxTabWidth130,
            
    orientation'vertical'
        
    },
        
    tabPosition'right',
        
        
    plaintrue
    }); 
    but you have to style it your own. :/ Sad, that Ext 4.1 doesnt completely support vertical tabs.
    Thank you for your help.
    I tried to style that for the different themes (normal and gray), or to simulate the tabs with Toolbar buttons and style them,
    but all these doesn't seem to really work .
    Overriding something (especially when CSS styles with "dynamic" names are also involved) seems very complicated with ExtJS .

    One of the main problems is that Ext 4.1. does not come with the required build tools (ext ZIP has the /build directory almost empty) and also the docs how to build Ext 4.1. itself. That would allow to change some base Ext files and SASS files and "recompile" everything (and also send Sencha the patch) .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •