Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Cannot get Mac to deploy to simulator in Architect

  1. #11
    Sencha User
    Join Date
    Dec 2011
    Location
    White Rock, BC Canada
    Posts
    167
    Vote Rating
    0
      0  

    Default

    @sapkalparag: I am not sure what you mean by "Hosting project inside a web server". My setup is: the project is in my /users/user/documents tree (which is not a web directory), but I am deploying to the web server (which is not Apache, but the default Mac one).

  2. #12
    Sencha User
    Join Date
    Dec 2011
    Location
    White Rock, BC Canada
    Posts
    167
    Vote Rating
    0
      0  

    Default

    On further research I found that the web server running on my Mac is indeed Apache.

  3. #13
    Sencha Premium Member
    Join Date
    Dec 2011
    Posts
    29
    Vote Rating
    1
      0  

    Default Well same problem here.

    I Also have this problem where it says "[ERROR] The current working directory (/Users/username) is not a recognized Sencha SDK or application folder

    Any help on this?

    When deploying via terminal I end up with a blank white screen, and I DID add an index.html

  4. #14
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    38
    Vote Rating
    2
      0  

    Default

    Thank you very much!!! You procedure worked for me regarding the simulator. Does the same thing have to be done for packaging (i.e. copy the app.html to index.html and then re-run the packager)?

  5. #15
    Sencha User
    Join Date
    Apr 2012
    Posts
    25
    Vote Rating
    0
      0  

    Default

    @rklowe01: yes. Same procedure.

    @
    WagsMax: Even i am kind of new to everything. N i tried alot but couldn't get myself to get the problem which u guys are facing.

    install apache tomcat
    start the server

    store ur project inside the /root directory inside the apache tomcat folder.
    give all ur links in the settings in architect as http://localhost:8080/path/toyour/project
    js to highlight: "http://localhost:8080/ " actually points to the root folder in apache folder.
    try n post wat happns......

  6. #16
    Sencha User
    Join Date
    Apr 2012
    Posts
    25
    Vote Rating
    0
      0  

    Default

    Hey rklowe01
    i read in a diff post that even u were facing the following issue...

    (/Users/user/path/to/project) is not a recognized Sencha SDK or application folder


    but later u were able to solve it.
    plz share exactly what changes u did so that it can help others also.
    Thanks.

  7. #17
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    38
    Vote Rating
    2
      0  

    Default

    I was still getting that error, but I just ignored it as it didn't seem to impact the simulation...

  8. #18
    Sencha User Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,953
    Vote Rating
    65
      0  
    Phil Strong
    @philstrong

  9. #19
    Sencha User
    Join Date
    Feb 2012
    Posts
    2
    Vote Rating
    0
      0  

    Default Having the same issue trying to run in iOS simulator. Help!

    I followed the suggestions earlier in the thread but continue to get the following:

    cd /Users/glenn_graham/Sites/citybars/
    sencha package run simulator.json
    [ERROR] The current working directory (/Users/glenn_graham/Sites/citybars) is not a recognized Sencha SDK or application folder
    The application was successfully packaged
    [DEBUG] Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=2 UserInfo=0x100615680 "Simulator session timed out."
    logout

    [Process completed]

  10. #20
    Sencha User
    Join Date
    Aug 2011
    Posts
    206
    Vote Rating
    8
      0  

    Default

    I've not tried to deploy direct to the simulator, but work around it a different way.

    Firstly, you have to be running a local host webserver. I use a mac, and I think mac even has its own webserver that can be turned on in the machine's properties - but I prefer to use XAMPP. Either way you end up with an htdocs folder which is your local webserver root - accessed via http://localhost

    As long as you can preview your app in the browser, you're set.

    Then run the iOS simulator. Just put iOS into the mac spotlight search to find it (for mac).
    Launch the mobile browser in the simulator. Type in the localhost URL where your app.html file is located, then when the page runs, add it to your simulator home screen. Now, every time you save and preview your app in the desktop browser, you can run the app icon in the sim and check your app full screen.

    Allister

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •