Results 1 to 6 of 6

Thread: Checkbox Focus/Blur Issue on Chrome

Hybrid View

Previous Post Previous Post   Next Post Next Post
    Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Ext JS Premium Member
    Join Date
    Jun 2009
    Posts
    52
    Vote Rating
    0
      0  

    Default Checkbox Focus/Blur Issue on Chrome

    Hello,

    I have an issue with using the checkbox focus/blur events on Chrome.

    On Chrome, when the user clicks on the checkbox, it doesn't trigger the focus and blur listener events, but it works as expected on Firefox and IE9. It seems the focus/blur events only get triggered if the user uses "Tab" button. Is it a bug or this is by design?

    This is the code I used to test:
    Code:
    <html>
      <head>
      <link href="/resources/css/ext-all.css" media="screen" rel="stylesheet" type="text/css" />
      <script type="text/javascript" src="/javascript/ext4/ext-all-debug.js"></script>
      <script type="text/javascript" src="/javascript/jquery/jquery-debug.js"></script>
      <script type="text/javascript">
        Ext.onReady(function() {
          var checkbox = Ext.create("Ext.form.field.Checkbox",
            {
              id: "checkbox_ID",
              renderTo: "checkbox_DIV",
              boxLabel: "Checkbox Test",
              listeners:
                {
                  focus: function(checkbox)
                    {
                      alert("focus");
                    },
                  blur: function(checkbox)
                    {
                      alert("blur");
                    },
                  afterrender: function(checkbox)
                    {
                      checkbox.inputEl.on("click", function()
                        {
                          $("#spanText").html("Checkbox is clicked!");
                        });
                    }
                }
            });
          });
      </script>
      </head>
      <body>
      <div id="checkbox_DIV"></div>
      <span id="spanText"></span>
      </body>
    </html>

  2. #2
    Sencha - Community Support Team jsakalos's Avatar
    Join Date
    Apr 2007
    Location
    Slovakia
    Posts
    27,664
    Vote Rating
    403
      0  

    Default

    Verified. I doesn't work in Safari either. Do you want this thread to be moved to Bugs?
    Jozef Sakalos, aka Saki

    Education, extensions and services for developers at new http://extjs.eu
    News: Grid MultiSearch Plugin, Grid MultiSort Plugin, Configuring ViewModel Hierarchy


  3. #3
    Ext JS Premium Member
    Join Date
    Jun 2009
    Posts
    52
    Vote Rating
    0
      0  

    Default

    Sure, thanks for checking!

  4. #4
    Sencha User
    Join Date
    Sep 2010
    Location
    Belgium
    Posts
    29
    Vote Rating
    0
      0  

    Default

    Any news on this?

  5. #5
    Sencha User
    Join Date
    Nov 2012
    Posts
    1
    Vote Rating
    0
      0  

    Default

    This seems to still be happening. Is this bug looking to be fixed in the near future?

  6. #6
    Sencha - Engineering Operations mike.estes's Avatar
    Join Date
    Mar 2011
    Location
    Redwood City, CA
    Posts
    221
    Vote Rating
    9
      0  

    Default

    This appears to be a webkit bug, see https://bugs.webkit.org/show_bug.cgi?id=22261

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •