Results 1 to 4 of 4

Thread: phonegap - white screen on second launch in simulator

  1. #1
    Sencha User
    Join Date
    Feb 2012
    Posts
    44
    Vote Rating
    0
      0  

    Default phonegap - white screen on second launch in simulator

    Everything works as expected if I delete the app from the simulator and relaunch but launching it a second time causes the 'white screen' effect. There's nothing in the log to help. Is there any chance the delta logic is causing the white screen? or something else that only happens the second time you load the app?

  2. #2
    Sencha User
    Join Date
    Feb 2012
    Posts
    44
    Vote Rating
    0
      0  

    Default

    Downgrading to phonegap 1.6.1 fixed the problem. Has anyone had luck running sencha touch on phonegap 1.7.0?

  3. #3
    Sencha User
    Join Date
    Feb 2012
    Location
    Virginia, USA
    Posts
    21
    Vote Rating
    0
      0  

    Default

    I tried building my Sencha Touch app with PhoneGap 1.7.0 and it crashed on startup. This occurred both in the Android emulator (2.3) and on an actual Android device.

    Had to go with PhoneGap 1.6.1 to make it work. No idea why, though.

  4. #4
    Sencha User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,029
    Vote Rating
    1368
      0  

    Default

    This blog post uses 1.7.0 and works. Lot of time if your app stops it is because a class wasn't required correctly.

    http://robertdougan.com/posts/packag...onegap-cordova
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Frontend Engineer
    ________________
    Need any sort of Ext JS help? Modus Create is here to help!

    Check out my GitHub:
    https://github.com/mitchellsimoens

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •