Results 1 to 2 of 2

Thread: Tabpanel not rendering the content

  1. #1

    Default Tabpanel not rendering the content

    Hello,

    I am trying to add a tab panel but i am not able to get the content to render at all, it displays the content if the height is set. There was a similar bug before 2.0 was released, i believe in the PR stage, i could not find anything else.

    here is my Main.js code
    Code:
    Ext.define("ICTablet.view.Main", {
        extend: 'Ext.Panel',
        id : 'main',
        layout:'fit',
        fullcreen:true,
        config: 
        {
            items: 
            [
                {
                    xtype : 'tabpanel',
                    defaults: {scrollable: true},
                    //height:'500px',
                    activeTab:0,
                    layout:'card',
                    tabBar : {
                                    docked: 'bottom',
                                    layout : {pack : 'center', align:'center'}
                    },
                    items :
                    [
                        {
                            title: 'About',
                            html: '<p>Docking tabs to the bottom will automatically chance their style.</p>',
                            iconCls: 'info'
                        }, 
                        {
                            title: 'Favorites',
                            html: '<p>Test.</p>',
                            iconCls: 'favorites',
                        }, 
                        {
                            title: 'Settings',
                            html: '<p>Test settings.</p>',
                            iconCls: 'settings',
                        }
                    ]
                }
            ]
        }
    });

    here is my viewport.js code

    Code:
    Ext.define('ICTablet.view.ViewPort',{
        extend : 'Ext.Panel',
        config : 
        {
            autoCreate : true,
            autoDestroy : true,
            fullscreen : true,
        },
    });
    I am using 2.0.1, any help is appreciated!

    Thanks

  2. #2

    Default

    i just realized i needed to add layout:'fit' and fullcreen:true, inside the config, after this everything worked

    Sorry for the post!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •