Results 1 to 8 of 8

Thread: [Resolved] How to disable Phone Number detection on iOS Device

  1. #1
    Sencha User
    Join Date
    Mar 2012
    Posts
    10
    Vote Rating
    1
      0  

    Default [Resolved] How to disable Phone Number detection on iOS Device

    I created a transaction history view, It contained transaction number in the view, the app will render the number as a phone number. When I scrolled the view it freeze because it took times to render transaction number. Please help me how to prevent my app (Sencha Touch) render a number as phone number on iOS Device.
    Thank so much!


    Last edited by nghiaquach; 27 Jun 2012 at 6:22 PM. Reason: resolved

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,556
    Vote Rating
    1272
      0  

    Default

    Is it a link or something? The device shouldn't be doing this.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  3. #3
    Sencha User
    Join Date
    Mar 2012
    Posts
    10
    Vote Rating
    1
      0  

    Default

    Thanks for your response . It just only a number in a List not a link but the application will render it as a link (When I click on the link, the device will show the option to add the number to the contact). I build my sencha touch application using phonegap 1.7.

  4. #4
    Sencha Premium Member
    Join Date
    Apr 2012
    Location
    Lausanne, Switzerland
    Posts
    196
    Vote Rating
    1
      0  

    Default

    Same problem, no answer? It even happens on the iOS Simulator.

  5. #5
    Sencha User rohdef's Avatar
    Join Date
    Mar 2010
    Location
    Aarhus, Denmark
    Posts
    67
    Vote Rating
    5
      0  

    Default

    A little Googling showed this: http://webmasters.stackexchange.com/...ers-into-links. I don't know if it works, but worth a try.
    Developer/Alien Technologies at Mobile Ambitions Aps, Denmark.

  6. #6
    Sencha User
    Join Date
    Mar 2012
    Posts
    10
    Vote Rating
    1
      0  

    Default

    Quote Originally Posted by rohdef View Post
    A little Googling showed this: http://webmasters.stackexchange.com/...ers-into-links. I don't know if it works, but worth a try.
    Hi rohdef, thanks for your help. I tried to add <meta name="format-detection"content="telephone=no" /> in index.html. However, It didn't work.

  7. #7
    Sencha Premium Member
    Join Date
    Apr 2012
    Location
    Lausanne, Switzerland
    Posts
    196
    Vote Rating
    1
      0  

    Default

    Does is appear on a real phone or only on a simulator?

    I've tried some real devices (not so much and only during a little time) and it only appears on my iOS Simulator.

  8. #8
    Sencha User
    Join Date
    Mar 2012
    Posts
    10
    Vote Rating
    1
      0  

    Default

    Quote Originally Posted by mcbl View Post
    Does is appear on a real phone or only on a simulator?

    I've tried some real devices (not so much and only during a little time) and it only appears on my iOS Simulator.
    Yes, It appeared on iOS simulator and my ipod(iOS 4.3) too.

  9. #9
    Sencha User
    Join Date
    Mar 2012
    Posts
    10
    Vote Rating
    1
      1  

    Default

    I've resolved the problem, I implemented webViewDidStartLoad as following:

    Code:
    - (void)webViewDidStartLoad:(UIWebView *)theWebView 
    
    {
    
        // disable telephone detection, basically <meta name="format-detection" content="telephone=no" />
        theWebView.dataDetectorTypes = UIDataDetectorTypeAll ^ UIDataDetectorTypePhoneNumber;
    
    
        return [ super webViewDidStartLoad:theWebView ];
    
    }

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •