Results 1 to 3 of 3

Thread: Ext.Application error dinamically loading files

  1. #1
    Sencha User
    Join Date
    Apr 2012
    Posts
    2
    Vote Rating
    0
      0  

    Default Answered: Ext.Application error dinamically loading files

    Hello!

    I'm building an app using Sencha Touch inside a Lotus Notes database and I'm experiencing a strange problem.
    I've managed to get the basic app to work perfectly until I tried to apply some MVC to it.
    While I was using only "app.js" file with all the code
    (models, views and etc.) inside it, it works normally. The problem happens when I try to split those things in separate files, and leaving the "app.js" file like below:


    Code:
    Ext.Loader.setConfig({    enabled: true
    });
    
    
    Ext.application({
        models: [
            'Requests'
        ],
        stores: [
            'ReqPending'
        ],
        views: [
            'ReqDetails',
            'MainPanel'
        ],
        name: 'DPAS',
    
    
        launch: function() {
    
    
            Ext.create('DPAS.view.MainPanel', {fullscreen: true});
        }
    
    
    });



    Then I got the following error:
    21-06-2012 18-00-35.jpg


    I've noticed that the code automatically adds a parameter "_dc=1340303380364" while trying to load the file and this is causing an error 400 Bad Request.
    What should I do?
    I don't want to throw away MVC structure and have to deal with a terrible huge "app.js" file.
    Thanks in advance for your help!

  2. Your server cannot handle that? What web server are you using? Apache handles it fine for me. YOu can remove it by doing:

    Code:
    Ext.Loader.setConfig({
        disableCaching : false
    });
    You can also try adding ?breakpoint to the url when you launch your app. This won't be an issue in production build as you won't be loading file dynamically.

  3. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,551
    Answers
    3931
    Vote Rating
    1271
      0  

    Default

    Your server cannot handle that? What web server are you using? Apache handles it fine for me. YOu can remove it by doing:

    Code:
    Ext.Loader.setConfig({
        disableCaching : false
    });
    You can also try adding ?breakpoint to the url when you launch your app. This won't be an issue in production build as you won't be loading file dynamically.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  4. #3
    Sencha User
    Join Date
    Apr 2012
    Posts
    2
    Vote Rating
    0
      0  

    Default

    Thanks for your help, this solved the problem.
    I'm not using any web-server. The Sencha app is built inside a Lotus Notes database.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •