Results 1 to 2 of 2

Thread: [Solved] AsyncTreeNode expand not firing?

  1. #1

    Post [Solved] AsyncTreeNode expand not firing?

    I'm working with the Ext 2.0 AsyncTree node, and can't seem to get the "expand" event to fire. Here's the relevant portion of code:

    Code:
    Ext.each(stations, function(o) {
         var station = root.appendChild(
              new Tree.AsyncTreeNode({
                      id:o.StationId
                   ,  text:o.Name
                   ,  attributes:{"Type":"Station","IsDirty":false,"Description":o.Description,"Tags":o.Tags}
                  , qtip :o.Description + " (click to play)"
                  , cls:'song-play-icon' 
                  , allowDrag:false 
                  , allowDrop:true
              })
         );
         station.on("click", function(){alert('foo')});
         station.on("expand", function(){alert('expand')});
    }, this);
    Pretty simple -- to be sure, the "click" event fires as advertised, but I can't get the "expand" event to fire.

    I'm sure this is something stupid/simple. Any ideas?
    Last edited by adkent; 7 Jan 2008 at 4:47 PM. Reason: solved the problem

  2. #2

    Default solved

    I was being stupid -- I had an Ext.tree.TreeLoader() in my TreePanel, which must prevent this event from firing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •