Results 1 to 8 of 8

Thread: Anyone tried GWT 2.5 with GXT 3 yet?

  1. #1
    Sencha Premium Member Neilcoder's Avatar
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    264
    Vote Rating
    0
      0  

    Default Anyone tried GWT 2.5 with GXT 3 yet?

    Would love to know if there are any known compatibility issues yet. If I understand correctly GXT 3 has moved in a direction so that it integrates better with GWT 2.4 by using more of the core of GWT. Might run an experiment. It says in the setup guide; "Note: GXT 3.X requires GWT 2.4+" so my guess is it should be fine. There are some nice new features in the release notes, like Super Dev Mode.

    https://developers.google.com/web-to..._Notes_Current

  2. #2
    Sencha - GXT Dev Team
    Join Date
    Feb 2009
    Location
    Minnesota
    Posts
    2,737
    Vote Rating
    93
      1  

    Default

    i just replied to a very similar question at http://www.sencha.com/forum/showthread.php?227544:

    "I test about once a week with GWT trunk, and have had no issues either with the build or with using the app. I would anticipate that will we officially support GWT 2.5 when it is released, but there are almost certainly aspects that are not completely tested yet, and cannot be until 2.5.0 is finalized.

    The GXT 3.0.0b build should work out of the box with GWT 2.5.0-rc1 - if you have any issues, please let us know."

    Once you get past the setup details of Super Dev Mode, it does indeed work with GXT 3. That said, I still find the standard dev mode preferable both in terms of setup, loading time, and ease of debugging, though I suspect this may change as more tools support it directly.

  3. #3
    Sencha Premium Member Neilcoder's Avatar
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    264
    Vote Rating
    0
      0  

    Default

    Thanks Colin!

  4. #4
    Sencha User
    Join Date
    Mar 2008
    Posts
    12
    Vote Rating
    0
      0  

    Default Small tutorial getting started

    Hi all,

    I just wrote a small tutorial how to get up to speed with GWT 2.5 and GXT 3.0, since the documentation on the Sencha site was a good basis, but bit outdated.

    You can find the updated tutorial here: http://www.jworks.nl/2012/08/13/gett...3-and-gwt-2-5/

    Kind regards,

    Erik Pragt

  5. #5
    Sencha Premium Member
    Join Date
    Jun 2010
    Posts
    42
    Vote Rating
    0
      0  

    Default

    Hi, I'm working well with both version at same time on my projects.

  6. #6
    Sencha User
    Join Date
    Nov 2011
    Posts
    16
    Vote Rating
    0
      0  

    Default

    I have developed one Grid component using GXT 3.0 UiBinder with GWT2.4, that worked fine without any issues. After upgrading to GWT2.5 the grid is not functioning properly like it is able to retrieve the data from database but it is not showing the rows in the grid.

    Can anyone help me on this.

    Thanks in advance..

  7. #7
    Ext GWT Premium Member
    Join Date
    Aug 2010
    Location
    Germany, Solingen
    Posts
    274
    Vote Rating
    3
      0  

    Default

    please, no double posts.

  8. #8
    Ext GWT Premium Member
    Join Date
    Aug 2010
    Location
    Germany, Solingen
    Posts
    274
    Vote Rating
    3
      0  

    Default

    I can confirm, that GXT 3.0 works well without GWT 2.5.
    Swith my project last week and had no trouble.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •