1. #1
    Sencha User
    Join Date
    May 2012
    Posts
    37
    Vote Rating
    1
    emprize is on a distinguished road

      0  

    Default performance on android

    performance on android


    I just try the example "kitchensink" in the sencha example folder on my galaxy note, which is dual core 1.4Ghz cpu and running ics 4.0.4, but i found out when i change tab on a tab panel, it is clearly a "delay", or laggy i should say? after i click the tab, it response after half a second, is it android problem or how can i optimize the performance? i also try write a simple example which only contain a tab panel to test it, the delay still there

  2. #2
    Sencha - Community Support Team sword-it's Avatar
    Join Date
    May 2012
    Location
    Istanbul
    Posts
    1,334
    Vote Rating
    87
    sword-it is just really nice sword-it is just really nice sword-it is just really nice sword-it is just really nice

      0  

    Default


    Hi!

    Try the following for the best performance for android devices:
    • Compress your JS & CSS files also remove any unused JS functions or CSS.
    • Try to load external JS files dynamically , check this http://stackoverflow.com/questions/1...sencha-touch-2
    • Avoid using CSS3 (Slow on Android)
    • Keep DOM structure smallest as possible
    • Do not use overscroll of any scrollviews in your application.(Should be disabled)
    sword-it.com, Sencha Developer House in Turkey - Istanbul University Technopark Suite 204.

  3. #3
    Sencha User
    Join Date
    Jan 2012
    Location
    London, UK
    Posts
    525
    Vote Rating
    87
    shepsii is just really nice shepsii is just really nice shepsii is just really nice shepsii is just really nice

      0  

    Default


    Hey sword-it,

    How are you preventing overscroll in your views? Can't see it in the docs! http://docs.sencha.com/touch/2-0/#!/...croll.Scroller

  4. #4
    Sencha - Community Support Team sword-it's Avatar
    Join Date
    May 2012
    Location
    Istanbul
    Posts
    1,334
    Vote Rating
    87
    sword-it is just really nice sword-it is just really nice sword-it is just really nice sword-it is just really nice

      0  

    Default


    Hi!

    you have to adjust the scrollviews's contentSize (size of container) to be equal to the area that you want scrollable.

    in that case, you may prevent scrolling
    sword-it.com, Sencha Developer House in Turkey - Istanbul University Technopark Suite 204.

  5. #5
    Sencha User
    Join Date
    Jan 2012
    Location
    London, UK
    Posts
    525
    Vote Rating
    87
    shepsii is just really nice shepsii is just really nice shepsii is just really nice shepsii is just really nice

      0  

    Default


    Hey,

    Sorry to ask for more details but I can't work this out... would you mind posting a basic example?

    Thanks!

  6. #6
    Sencha User
    Join Date
    Jul 2011
    Location
    Utrecht
    Posts
    84
    Vote Rating
    3
    DJFliX is on a distinguished road

      0  

    Default


    I am also very interested in getting my hands on an example.

  7. #7
    Sencha User
    Join Date
    Jan 2012
    Location
    London, UK
    Posts
    525
    Vote Rating
    87
    shepsii is just really nice shepsii is just really nice shepsii is just really nice shepsii is just really nice

      1  

    Default


    setting the scroller to this sorts it:

    Code:
    scroller: {
          direction: 'vertical',
          directionLock: true,
          momentumEasing:  {
            momentum: {
              acceleration: 30,
              friction: 0.5
            },
            bounce: {
              acceleration: 0.0001,
              springTension: 0.9999
            },
            minVelocity: 5
          },
          outOfBoundRestrictFactor: 0
        }

  8. #8
    Sencha User riyaad's Avatar
    Join Date
    Jul 2011
    Location
    Cape Town
    Posts
    245
    Vote Rating
    1
    riyaad is on a distinguished road

      0  

    Default Thank you

    Thank you


    Nice one