Results 1 to 2 of 2

Thread: Problem with tab strip disappearing in 4.1.0 (not in 4.0.7)

  1. #1
    Sencha Premium User
    Join Date
    Sep 2011
    Location
    Tamworth, NSW, Australia
    Posts
    1,353
    Answers
    13
    Vote Rating
    424
      0  

    Question Answered: Problem with tab strip disappearing in 4.1.0 (not in 4.0.7)

    I have designed a system that is based on a tabpanel in the center region of a border layout. In 4.0.7 this worked fine, but in 4.1.0 the tabs in the tap strip are disappearing whenever I click on the first tab. I can't think of anything special about the contents of the tab (I'm using itemId's only, not ID's).

    Is there a known problem with tabpanels in 4.1.0 whereby the tabs disappear? Strangely, this problem is also happening to buttons in a my toolbar in the north region of the border layout (which sometimes also disappear when clicking on tabs). When I was using ID's early in the piece, I noticed these strange behaviours, so I replaced everything that had an ID with an itemId, and the problem was sorted. Now that I'm testing my code against 4.1.0, this strange behaviour seems to be back insofar as tabpanels and toolbars are concerned.

  2. Problem solved. I had a fieldset with a "height: 200" specified and it was the cause of the problem. Strangely enough, if I switched this offending tabpanel to be the 3rd tab, everything was fine, but if it's the first tab, you get disappearing tabs with this height setting in place.

    Sencha Architect lets me specify the height, but if I do so, I get this weird behaviour. I don't need the height (and can't remember adding it) so I'll just ditch it.

  3. #2
    Sencha Premium User
    Join Date
    Sep 2011
    Location
    Tamworth, NSW, Australia
    Posts
    1,353
    Answers
    13
    Vote Rating
    424
      0  

    Default

    Problem solved. I had a fieldset with a "height: 200" specified and it was the cause of the problem. Strangely enough, if I switched this offending tabpanel to be the 3rd tab, everything was fine, but if it's the first tab, you get disappearing tabs with this height setting in place.

    Sencha Architect lets me specify the height, but if I do so, I get this weird behaviour. I don't need the height (and can't remember adding it) so I'll just ditch it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •