Results 1 to 2 of 2

Thread: "ignore" property in configTemplate.json not working

  1. #1
    Touch Premium Member
    Join Date
    Jul 2011
    Posts
    11

    Default "ignore" property in configTemplate.json not working

    Hello everyone,

    I'm using version 2.0.3 of Sencha Command on Windows 7 64 bit. When I execute "sencha package build configTemplate.json" the build pulls in all my .svn directories, despite having an ignore of ".svn". I was referencing this post:
    http://www.sencha.com/forum/showthre...ies-.svn-files

    Checking Application.js, the fix Jacky was referring to is already there. It seems that the above command uses a different version of the script, or runs it with different settings. If I run "sencha app build native", then the .svn directories are correctly ignored, but I'm not sure how to point it towards the configTemplate.json file. I have the ignore in both app.json and configTemplate.json.

    Should I be using "sencha app build native" and just update app.json with all of my build information in configTemplate.json? I ran across the "sencha package build <configFile>" syntax in one of the blog posts. Or am I missing a setting somewhere and should stick with "sencha package build <configFile>"?

    Thank you,
    -jed

  2. #2
    Touch Premium Member
    Join Date
    Jul 2011
    Posts
    11

    Default

    Well, I figured out that renaming "configTemplate.json" to "packager.json" is what was needed to get that config file being read by "sencha app build native". For now, I've switched to using that command to build the native app as I just tested it on my iPad and it seems to be working correctly.

    So the solution for now is to not use "sencha package build <fileName>.json" when working with code under source control.

    Thank you,
    -jed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •