Results 1 to 4 of 4

Thread: TypeError:’undefined’ is not an object while loading app on iOS 5

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Sencha User
    Join Date
    Jun 2012
    Posts
    7
    Vote Rating
    0
      0  

    Default TypeError:’undefined’ is not an object while loading app on iOS 5

    Hello,
    I've got problem with my application. Basically it won't load when I use iPad with iOS 5.1.1. It shows only wait indicator and after a few minutes I'm getting an Error:
    JavaScript: Error
    Undefined
    TypeError:’undefined’ is not an object
    On the other iPad with iOS 4.3 everything seems to be working fine.
    Any thoughts what can cause it ?
    Thanks!

  2. #2
    Sencha Premium Member
    Join Date
    Jan 2012
    Location
    London, UK
    Posts
    587
    Vote Rating
    88
      0  

    Default

    Yeh I've had this before too. It is ugly to debug because safari doesn't give you a line number.

    The error I had was even worse because on desktop safari it was fine. Yuck!

    I wish I could tell you there's a magic way to fix it, but there isn't one that I know of... just lots of console.log()s at certain points in your app until you work out where execution is stopping. That was a fun 3 hours of my life !!

  3. #3
    Sencha User
    Join Date
    Jul 2012
    Posts
    1
    Vote Rating
    0
      0  

    Default

    I've managed to recreate the same problem by going to Kitchen Sink in Safari (5.1.7, Win7) and by using iPhone (iOS 5.1.1). The only trick was to enter Private Browsing mode in Safari.


    Javascript Console gave me:
    TypeError: 'undefined' is not an object (evaluating 't.assets')
    /deploy/touch/examples/production/kitchensink/:9


    Looks like a problem with microloader/production.js, when HTML5 localStorage is blocked by Private Browsing in Safari.

  4. #4
    Sencha Premium Member
    Join Date
    Apr 2008
    Posts
    356
    Vote Rating
    86
      0  

    Default

    I've verified this in the latest public/working ST2 and SDK tools beta3

    This makes all apps crash and burn silently on any iOS device with private browsing enabled. Why hasn't this been marked as a bug? Will it be resolved in CMD / ST2.1? Can we get a patch for existing apps built with ST2.0 and SDKtoolsB3?
    Chief Architect @ Jarv.us Innovations
    Co-captain @ Code for Philly

    Jarvus builds and optimizes top-quality Sencha Touch and ExtJS apps for open-source projects and clients of all sizes.

    Don't waste time with bugs that have already been found and fixed by the community, compile our tried and tested hotfixes packages into all your projects: https://github.com/JarvusInnovations/sencha-hotfixes

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •