Results 1 to 3 of 3

Thread: Toolbar button padding: cannot set to 0

  1. #1
    Sencha User
    Join Date
    Jul 2012
    Location
    New Jersey
    Posts
    116
    Answers
    6
    Vote Rating
    5
      0  

    Default Answered: Toolbar button padding: cannot set to 0

    I'm trying to set the padding for the buttons in my toolbar to 0. The css I need to change is:

    Code:
    /* line 209, ../themes/stylesheets/sencha-touch/default/widgets/_buttons.scss */
    .x-button.x-button-plain,
    .x-toolbar .x-button.x-button-plain {
      background: none;
      border: 0 none;
      -webkit-border-radius: none;
      border-radius: none;
      min-height: 0;
      text-shadow: none;
      line-height: auto;
    /*  height: 1.9em; MODIFIED: MC*/
      padding: 0em 0.5em;
    }

    I know this because if I change it in Chrome debugger it works. However, I'm trying to use the cls
    attribute on my toolbar like :
    cls:'my-toolbar'
    so I have this in my css:

    Code:
     .
    my-toolbar
    .x-button.x-button-plain { padding: 0em 0em; }
    but it does not work . I've tried a bunch of other combinations as well. How should my css be specified to change the padding to 0?

  2. Have you tried adding the !important flag with your style?
    Code:
    padding: 0em !important;

  3. #2
    Sencha User jerome76's Avatar
    Join Date
    Apr 2012
    Location
    New Jersey
    Posts
    1,149
    Answers
    132
    Vote Rating
    101
      0  

    Default

    Have you tried adding the !important flag with your style?
    Code:
    padding: 0em !important;

  4. #3
    Sencha User
    Join Date
    Jul 2012
    Location
    New Jersey
    Posts
    116
    Answers
    6
    Vote Rating
    5
      0  

    Default

    ah! forgot about that. - thx!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •