Hey guys, I have run into a bit of a unique problem here. I'm a 14 year old just getting into sencha due to hearing how easy it was to use. This is my first forum post and first app.

So I've been experimenting around with Sencha IO and I first deployed my app in (Didn't read the warning about it only working on 2.0.0). The login view worked as well as the Usergroup (It incremented).

Whilst doing more research, I read about the warning saying that Sencha IO only worked with 2.0.0.

I redownloaded Sencha and generated a skeleton app with sencha generate app. I ran this command from the root of the Sencha 2.0.0 file and made sure to do it in a seperate folder system. I copied and pasted my app.js, app folder, app.json, index.html, packager.json, and io sdk. I fixed all the routes and such. But when I try to compress it and upload it to deploy it, it is too Large for the allowed upload size of 20 MB. I dont know why the SDK of ST2.0.0.0 is 85 MB. Which is 4x the Allowance of file upload for Sencha IO deployment. I checked the size of the SDK folder in the root directory of my generated app, and it was a mere 17 MB uncompressed.

Unfortunately the compressed 2.0.0 file was around 45 MB's, so I couldn't even try to deploy it and see how sencha IO worked with 2.0.0.

I revisited using sencha IO with and voila, the login worked for both my dad and myself, with incrementing users in the user group. So how do I go about this?

Does anyone have any knowledge on how to do a workaround on the file size or if supports IO, which it seems to be doing?

Thanks for your time.