Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Events not detected in production build

  1. #1

    Default Events not detected in production build

    The UI loads correctly, however none of the mouse events/listeners are being invoked.

    Any pointers...greatly appreciated..

    extjslikeit

  2. #2
    Sencha Premium User bluehipy's Avatar
    Join Date
    Mar 2010
    Location
    Romania
    Posts
    628
    Answers
    67

    Default

    Give us more.

  3. #3

    Default

    If the app is tested in dev mode the UI works perfectly, however when in production mode the ui load but no events work such as scrolling, itemtap etc. It is the same source files but concatenated.

  4. #4
    Sencha Premium User bluehipy's Avatar
    Join Date
    Mar 2010
    Location
    Romania
    Posts
    628
    Answers
    67

    Default

    Any errors or warnings in console?

  5. #5

    Default

    None

  6. #6

    Default

    I notice that if I keep

    <script type="text/javascript" src="sdk/sencha-touch-all.js"> </script>

    after my script file, I get bunch of not defined errors however the UI loads and it works, ie events work

    If

    <script type="text/javascript" src="sdk/sencha-touch-all.js"> </script>

    is before any script the UI loads but none of the events work

  7. #7
    Sencha Premium User bluehipy's Avatar
    Join Date
    Mar 2010
    Location
    Romania
    Posts
    628
    Answers
    67

    Default

    Framework script should be first. Before it Ext is not defined.

    Show source code. I can't imagine a reason for this behavior. Actually I can imagine but I can't guess which one is your case

  8. #8

    Default tried production and test build commands with no success

    No events seem to work in the UI in production or test build.

  9. #9

    Default I am testing in Google Chrome (21.0.1180.83 m)

    Not wrking

  10. #10

    Default

    Tested in safari on iPad simulator with no luck.

    There are no messages in log except the ones I added..

    The same script files work perfectly in development mode..

    We need to get this to work for our prototype...It would be sad to not be able to use sencha touch due to this issue...

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •