Results 1 to 6 of 6

Thread: ExtJS 4.1.1 Accessibility support

  1. #1
    Sencha Premium Member
    Join Date
    Feb 2012
    Location
    New Delhi
    Posts
    7
    Vote Rating
    0
      0  

    Post Unanswered: ExtJS 4.1.1 Accessibility support

    I want to add Accessibility support in extjs 4.1.1 components, i have looked at the accessibility video on sencha websites, is there are any documentation available which tells the methods to be overridden for adding custom accessibility messages, I understand ariaRole property is there and needs to be overridden in config, I want all the properties/ methods available in every extjs component.

    Do I need to add my custom key events in every component so that screen readers can understand?

    I need to follow guidelines like this: http://www.w3.org/TR/wai-aria-practi...cessiblewidget

    Thanks
    Rishi

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,388
    Answers
    716
    Vote Rating
    499
      0  

    Default

    Support for ARIA is slated for 4.2 at this time.

    Scott.

  3. #3
    Sencha Premium Member
    Join Date
    Feb 2012
    Location
    New Delhi
    Posts
    7
    Vote Rating
    0
      0  

    Default

    Thanks, Is 4.2 release expected by end of 2012?

  4. #4
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,388
    Answers
    716
    Vote Rating
    499
      0  

    Default

    There is no public release date available at this time.

    Scott.

  5. #5
    Sencha User
    Join Date
    Apr 2013
    Posts
    2
    Vote Rating
    1
      0  

    Default Ext JS 4.2 Accessibility Support

    The previous reply to this question was "support for ARIA is slated for 4.2 at this time." Now that 4.2 is available, it does not appear to be fully compliant. Is ARIA support now slated for a new 4.x release? Which one?

    Thanks.

  6. #6
    Sencha User
    Join Date
    Jan 2014
    Posts
    11
    Vote Rating
    0
      0  

    Default Accessibility support in ExtJS 4.2

    How to use ARIA 2.0 "ariadescribed-by" property in ExtJs 4.2 components?? in ExtJs4.2 we have only ariaRole config property.. how to implement other ARIA properties??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •