Results 1 to 2 of 2

Thread: Error when including sencha-touch.js but not sencha-touch-debug.js

  1. #1
    Sencha User
    Join Date
    Feb 2012
    Location
    Toronto, Canada
    Posts
    25

    Default Error when including sencha-touch.js but not sencha-touch-debug.js

    I recently upgraded my sencha touch 2 version to beta 3 and ever since then i have been having problems. The error message i am getting is "Cannot call method 'substring' of undefined". I made sure to add the below code after including sencha-touch-debug.js.

    Code:
    Ext.Loader.setConfig({
        enabled:true,
        paths:{
    	  'Ext':'lib/touch/src'
        }
    });
    But even that doesnt help the problem. Also i made sure to to use Ext.require to request all the required classed. Please help.

  2. #2
    Sencha User
    Join Date
    Feb 2012
    Location
    Toronto, Canada
    Posts
    25

    Default Error when including sencha-touch.js but not sencha-touch-debug.js (SenchaTouch2 b3)

    I found out that the issue is with the show function of Ext.Msg. When I call the function Ext.Msg.alert i get that same error even when all my other code has been commented out. Any Ideas?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •