Results 1 to 3 of 3

Thread: deactivate event not fired on windows

    Wait! Looks like we don't have enough information to add this to bug database. Please follow this template bug format.
  1. #1
    Sencha Premium Member
    Join Date
    Dec 2010
    Posts
    49
    Vote Rating
    2
      0  

    Default deactivate event not fired on windows

    Ext version: Ext JS v 4.1.1

    I believe that error is in method ZIndexManager._activateLast which deletes this.front.
    Later setActiveChild cannot call deactivate on this.front.
    Checkout Dextop or Pecunia demo.

  2. #2
    Sencha User evant's Avatar
    Join Date
    Apr 2007
    Location
    Sydney, Australia
    Posts
    18,967
    Vote Rating
    931
      0  

    Default

    Under what circumstances? When closing the window? When focusing another one?
    Twitter - @evantrimboli
    Former Sencha framework engineer, available for consulting.
    As of 2017-09-22 I am not employed by Sencha, all subsequent posts are my own and do not represent Sencha in any way.

  3. #3
    Sencha Premium Member
    Join Date
    Dec 2010
    Posts
    49
    Vote Rating
    2
      0  

    Default

    Quote Originally Posted by evant View Post
    Under what circumstances? When closing the window? When focusing another one?
    This happens when you have a few open windows (desktop example) and you're switching between them. The window which is activated fires 'activate' event, but deactivated window does not fire 'deactivate'.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •