Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 44

Thread: [Sencha Cmd 3.0.0.122 / 3.0.0.141] Native apps fail on iOS 6 (run well on iOS 5)

    Success! Looks like we've fixed this one. According to our records the fix was applied for TOUCH-3494 in a recent build.
  1. #21
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    646
    Vote Rating
    40
      0  

    Default

    I'm trying to build on MAC OS X Lion today.. I hate booting it up, but since sencha is using mac I think it more likevely to have been rested there.

    I've never built on a Mac before. I'm able to run the app fine in the simulator now, but I'm not able to build the native package. I get an error message about "No identify found".
    Same message as reported here: http://www.sencha.com/forum/showthre...ileprovision-)

    I'm upgrading the Mac to Mountain Lion now (10.8.2) to see if that helps, since the jafingi reports that it may be a Lion (10.7) problem only... Then again, it may just be that I'm missing something about how I should handle the cert install (downloaded root CA and Dev CA - installed both to KeyChain)
    Sven Tore Iversen

  2. #22
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    646
    Vote Rating
    40
      0  

    Default

    Just tested with Mountain Lion, same cert problem
    Sven Tore Iversen

  3. #23
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    646
    Vote Rating
    40
      0  

    Default

    ...sorry for hammering the thread, but I solved the cert issue, but ran into into a new one.

    Code:
    [INFO ]		Packaging your application as a native app...
    [ERROR]		failed running native packager
    [ERROR]		/Library/WebServer/Documents/ecosupport/tmp/build/native//EcoInteractive.app: object file format unrecognized, invalid, or unsuitable
    The application was successfully packaged
    Failed to execute system command while signing application with error 256
    Failed to package application
    
    [ERROR]		Exception running app build : JavaException: com.sencha.exceptions.ExBuild: failed running native packager
    [ERROR]		javax.script.ScriptException: JavaException: com.sencha.exceptions.ExBuild: failed running native packager in <Unknown source> at line number 709
    bash-3.2$
    Will look more into this one tomorrow...
    Sven Tore Iversen

  4. #24
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    646
    Vote Rating
    40
      0  

    Default Working on OSX

    I actually got it working now on OSX
    Last issue was solved, thanks to this guy:
    http://www.sencha.com/forum/showthre...-Mountain-Lion

    I copied the native package back to the windows computer, installed in the iPad device with iOS 6 and started the application - all seems to be working

    ..soo it looks like the iOS 6 issue is resolved, but building on Windows is currently not working
    Sven Tore Iversen

  5. #25
    Sencha User VladimirTechMan's Avatar
    Join Date
    Jun 2012
    Location
    Russia
    Posts
    50
    Vote Rating
    4
      0  

    Default

    Thanks, Sven! It is really good to know the result. That way it means that we will have to wait for Sencha to release another update of Cmd, a one that correctly signs the native iOS apps on Windows. Hope it will not take them ages...

  6. #26
    Sencha User Jamie Avins's Avatar
    Join Date
    Mar 2007
    Location
    Redwood City, California
    Posts
    3,661
    Vote Rating
    19
      0  

    Default

    Re-opening this to look into the Windows issue. We should be able to update Command separately for this.

    Sencha Inc

    Jamie Avins

    @jamieavins

  7. #27
    Sencha User VladimirTechMan's Avatar
    Join Date
    Jun 2012
    Location
    Russia
    Posts
    50
    Vote Rating
    4
      0  

    Default

    Many thanks, Jamie! I hope you and your colleagues will be able to debug and fix this issue soon. Indeed, you may also want to look at bug [TOUCH-3461], which is about signing native apps not working on Windows (I originally reported it here).

  8. #28
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    646
    Vote Rating
    40
      0  

    Default

    FYI
    3.0.0.190 does not solve the issue...

    Change log does not mention that it should either though..
    Sven Tore Iversen

  9. #29
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    646
    Vote Rating
    40
      0  

    Default

    3.0.0.201 (RC2) does not solve the issue on Windows, app is never signed.

    Will try again on OSX (should be fixed for OSX)
    Sven Tore Iversen

  10. #30
    Sencha User voloshyn's Avatar
    Join Date
    Jan 2012
    Posts
    118
    Vote Rating
    1
      0  

    Default

    I'm now able to reproduce the issue and working on a fix

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •