Ext version tested:
  • Sencha Touch 2.1rc1

Browser versions tested against:
  • N/A

DOCTYPE tested against:
  • html

  • If you create an app using Sencha Command, the app's classes are stored in an "app" folder. In previous versions of the command, you could customize this folder. Now I get an error when I try to build an app with a custom folder.

Steps to reproduce the problem:
  • Run "sencha generate app ..." to create an app.
  • In app.js, change the "Ext.Loader.setPath" command. Instead of 'default': 'app', use 'default': 'customfolder'.
  • Rename the "app" folder to "customfolder".
  • Run "sencha app build production".

The result that was expected:
  • Builds correctly.

The result that occurs instead:
  • Shows the following output:
    Sencha Cmd v3.0.0.188
    [INFO ]		init-properties:
    [INFO ]		init-sencha-command:
    [INFO ]		init:
    [INFO ]		-before-app-build:
    [INFO ]		app-build-impl:
    [INFO ]		building application
    [INFO ]		Deploying your application to /Users/myuser/test/build/default/production
    [INFO ]		Copied app.js
    [INFO ]		Copied resources/css/app.css
    [INFO ]		Copied /Users/myuser/test/resources/icons
    [INFO ]		Copied /Users/myuser/test/resources/startup
    [INFO ]		Resolving your application dependencies (file:////Users/myuser/test/index.html)
    [INFO ]		Compiling app.js and dependencies
    [INFO ]		Processing classPath entry : /Users/myuser/test/sencha-compile-temp-dir
    [INFO ]		Processing classPath entry : /Users/myuser/test/touch/src
    [INFO ]		Processing classPath entry : /Users/myuser/test/app.js
    [INFO ]		Processing classPath entry : /Users/myuser/test/app
    [WARN ]		[ [1000] : Yui Compressor Warning <> Trailing comma is not legal in an ECMA-262 object initializer => }, function() { ] :: ( /Users/myuser/test/touch/src/app/Controller.js => 625 : 1 )
    [ERROR]		def was null
    [ERROR]		failed to find meta class definition for name default.view.Main
    [ERROR]		Exception running app build : JavaException: com.sencha.exceptions.BasicException: null
    [ERROR]		javax.script.ScriptException: [object Error] (<Unknown source>#709) in <Unknown source> at line number 709
  • Also note the warning from YUI compressor.

Test Case:

See above.


Screenshot or Video:
  • N/A

See this URL for live test case: N/A

Debugging already done:
  • Also tried adding "appFolder": "customfolder" to the app config, but got the same result.

Possible fix:
  • not provided

Additional CSS used:
  • only default ext-all.css

Operating System:
  • Mac OS 10.8.2