Results 1 to 6 of 6

Thread: Can't set proxy *Param properties to undefined

    Success! Looks like we've fixed this one. According to our records the fix was applied for a bug in our system in a recent build.
  1. #1
    Sencha User
    Join Date
    Sep 2012
    Posts
    4
    Vote Rating
    1
      1  

    Default Can't set proxy *Param properties to undefined

    REQUIRED INFORMATION
    Architect Build tested:
    • Build: 640
    Project Type:
    • ExtJS 4.x
    Description:
    • Can't set proxy *Param properties to undefined (limitParam, pageParam, startParam, etc)
    • The documentation states if we want to send these params we need to set the value to undefined. SA 2 does not allow this.
    Steps to reproduce the problem:
    • Create a model witha proxy. Try to set the limitParam = undefined.
    The result that was expected:
    • Code:
      limitParam: undefined
    • limit param is not sent with request
    The result that occurs instead:
    • Code:
      limitParam: 'undefined'
    • limit param is now named 'undefined' and sent with the request
    HELPFUL INFORMATION
    Screenshot, Project, or Video:
    • NA
    Possible fix:
    Operating System:
    • WinXP Pro
    • OS X 10.7.5

  2. #2
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,488
    Vote Rating
    147
      0  

    Default

    Thanks, we're aware of this issue.

    You can currently set it via an override or hook onto the beforeload event as indicated in the linked thread.
    Aaron Conran
    @aconran

  3. #3
    Sencha User
    Join Date
    Jul 2014
    Posts
    10
    Vote Rating
    2
      0  

    Default

    Is there any progress on this?

  4. #4
    Sencha User jjohnston's Avatar
    Join Date
    Sep 2010
    Posts
    567
    Vote Rating
    21
      0  

    Default

    There has been progress indeed! It wasn't loudly announced but Architect now allows you to set literal null, undefined, and empty-string values for most configs by right-clicking on them. See the screenshot below, where I've set undefined for the limitParam config.

    433264969861.jpg
    Jason Johnston
    @lojjic
    Sencha Architect Development Team

  5. #5
    Sencha User
    Join Date
    Jul 2014
    Posts
    10
    Vote Rating
    2
      0  

    Default

    I'm using architect 3.0.4.1386 and I don't have this option. How can I upgrade to a version which supports this feature?

  6. #6
    Sencha User jjohnston's Avatar
    Join Date
    Sep 2010
    Posts
    567
    Vote Rating
    21
      0  
    Jason Johnston
    @lojjic
    Sencha Architect Development Team

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •