Results 1 to 4 of 4

Thread: ST 2.0.1.1 Native Package Problems w/iOS6

Hybrid View

Previous Post Previous Post   Next Post Next Post
    Wait! Looks like we don't have enough information to add this to bug database. Please follow this template bug format.
  1. #1
    Ext JS Premium Member
    Join Date
    Dec 2011
    Location
    Sunrise Beach, MO
    Posts
    23
    Vote Rating
    1
      0  

    Default ST 2.0.1.1 Native Package Problems w/iOS6

    Without referencing current reported bugs with ST 2.0.1.1 and iOS 6, my team and I are hindered for product testing until the issue(s) are resolved. Is there any defined date on when we can expect a resolve?

    To recap the issue. We can successfully package and deploy to Android devices fine. When attempting to build native iOS, the package claims to have built. Then I manually sign the app w/codesign which reports a success. Deploying to a 1st generation iPad (iOS 5) works fine. Whenever deployed to an iOS 6 device, it claims success but when ran, you see a Sencha splash screen then an immediate shutdown.

    I would think iOS 6 support would be a priority.

    Is this something that's already been addressed in 2.0.3 or one of the licensed builds?

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,553
    Vote Rating
    1272
      0  

    Default

    It's hard to say if it has been fixed or not without knowing the actual issue. YOu can use a remote debugger like weinre to find out what the error was.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  3. #3
    Ext JS Premium Member
    Join Date
    Dec 2011
    Location
    Sunrise Beach, MO
    Posts
    23
    Vote Rating
    1
      0  

    Default Detail

    Identical to the issues described here:

    http://www.sencha.com/forum/showthre...well-on-iOS-5)

    Same result when attempting from Windows or is OSX. Runs in the simulator, on iOS 5 devices and on Android.

  4. #4
    Ext JS Premium Member
    Join Date
    Dec 2011
    Location
    Sunrise Beach, MO
    Posts
    23
    Vote Rating
    1
      0  

    Default Resolved

    I was able to resolve this issue myself.

    While manually signing the package, the command line included a reference to an entitlements file. Removing this reference and it runs as expected on both iOS 5 and iOS 6 devices.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •