Results 1 to 2 of 2

Thread: Native packaging an ST2 app for simulator or device

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    80
    Answers
    3
    Vote Rating
    0
      0  

    Default Unanswered: Native packaging an ST2 app for simulator or device

    Hi,
    I have now tried for the past 12 weeks to try to achieve this which I was hoping was pretty simple, but no luck and no useful response to prior posts. Going thru dozens of hints from other posts I made little steps but at some point I got new problems or error messages.

    Isn't there a guide or some piece of documentation that describes with a small sample what has to be done to package an app and run it on an iPhone for example?

    So far I was able to package my app and load it onto my iPhone (via iTunes). The app starts but that is it. When I press a button nothing happens (when I run the app via Safari or Chrome everything is fine, so I assume that something gets broken in the conversion process).

    So I thought that I try to build the app for the iOS simulator but that results in new errors, like:
    Code:
    /Users/xx/bin/Sencha/Cmd/3.0.0.181/sencha app build native /Users/xx/Sites/st2/app/simulator.json
    Sencha Cmd v3.0.0.181
    [ERROR]        Unable to locate 'app.dir' config property from sencha.cfg
    [ERROR]        Please ensure this command was executed from a valid application directory
    [ERROR]        Non-appliaction directory
    Not sure what this is trying to tell me. I know that there are many other developers struggling with similar issues so wouldnt it be great to have some guidance?

    Another thing I tried (from some Sencha recommendation), which resulted in an error as well:
    Code:
    /Users/xx/bin/Sencha/Cmd/3.0.0.181/sencha ant native build /Users/xx/Sites/st2/app/simulator.json
    Sencha Cmd v3.0.0.181
    [ERROR]        java.io.FileNotFoundException: /Users/xx/bin/Sencha/Cmd/3.0.0.181/build.xml (No such file or directory)
    One more thing: when I follow the instructions from the Sencha Touch docu Iget this:
    Code:
    /Users/xx/bin/Sencha/Cmd/3.0.0.181/sencha package run /Users/xx/Sites/st2/app/simulator.json
    Sencha Cmd v3.0.0.181
    [ERROR]		
    [DEBUG] Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=2 "Simulator session timed out." UserInfo=0x7f85b30a8690 {NSLocalizedDescription=Simulator session timed out.}
    The application was successfully packaged
    
    
    [ERROR]		stbuild exited with non-zero code : 1


    Thanks.

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,421
    Answers
    3901
    Vote Rating
    1271
      0  

    Default

    The error you got from the first snippet:

    Please ensure this command was executed from a valid application directory
    You are in the Sencha Cmd directory, you need to be within your application directory and execute

    Code:
    sencha app build native
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it!

    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •