I have now tried for the past 12 weeks to try to achieve this which I was hoping was pretty simple, but no luck and no useful response to prior posts. Going thru dozens of hints from other posts I made little steps but at some point I got new problems or error messages.

Isn't there a guide or some piece of documentation that describes with a small sample what has to be done to package an app and run it on an iPhone for example?

So far I was able to package my app and load it onto my iPhone (via iTunes). The app starts but that is it. When I press a button nothing happens (when I run the app via Safari or Chrome everything is fine, so I assume that something gets broken in the conversion process).

So I thought that I try to build the app for the iOS simulator but that results in new errors, like:
/Users/xx/bin/Sencha/Cmd/ app build native /Users/xx/Sites/st2/app/simulator.json
Sencha Cmd v3.0.0.181
[ERROR]        Unable to locate 'app.dir' config property from sencha.cfg
[ERROR]        Please ensure this command was executed from a valid application directory
[ERROR]        Non-appliaction directory
Not sure what this is trying to tell me. I know that there are many other developers struggling with similar issues so wouldnt it be great to have some guidance?

Another thing I tried (from some Sencha recommendation), which resulted in an error as well:
/Users/xx/bin/Sencha/Cmd/ ant native build /Users/xx/Sites/st2/app/simulator.json
Sencha Cmd v3.0.0.181
[ERROR]        java.io.FileNotFoundException: /Users/xx/bin/Sencha/Cmd/ (No such file or directory)
One more thing: when I follow the instructions from the Sencha Touch docu Iget this:
/Users/xx/bin/Sencha/Cmd/ package run /Users/xx/Sites/st2/app/simulator.json
Sencha Cmd v3.0.0.181
[DEBUG] Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=2 "Simulator session timed out." UserInfo=0x7f85b30a8690 {NSLocalizedDescription=Simulator session timed out.}
The application was successfully packaged

[ERROR]		stbuild exited with non-zero code : 1