Since I ran into some trouble deploying my app to my iPad i thought it would be good to use the latest version of sencha command.

My troubles were that that the app was recognized in itunes, but syncing it to the device did not complete.
After viewing several forums, I saw messages of "App successfully signed" after the message that the app was packaged correctly. Therefore my indication was that possibly my build of sencha cmd was faulting and i decided to upgrade it.

I am using Sencha Touch v2.1-beta 3.

Now after trying to run Sencha app build native, i get the message that a file called build.xml was not found in my application folder.

I tried using Sencha app upgrade -p <path to framework>, but that leaves me with an error "Failed to determine framework name" and a corrupt application.

Also generating a new app to view the contents of this build.xml file results in the same error.

I start to believe that this version of sencha command an the version of sencha touch are not really compatible.

Anyone an idea?

-- Edit --
Rebuilt the application with, still no message of signing, but now syncing with iPad completes with an installation failure. The problem were some invalid png files that were added by default by sencha command. Now looking to solve the next error: could not save thumbnail for downloading icon: image=(null)