Results 1 to 5 of 5

Thread: ExtJS 4.1 "no method substring"

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Sencha User
    Join Date
    Apr 2012
    Marseille, France
    Vote Rating

    Default Answered: ExtJS 4.1 "no method substring"


    I want to create a chart. With my previous version of ExtJS it worked, but with ExtJS 4.1 not.
    I get my data array from a servlet and then I create a Record:
    var recordLinks = new Array(9);
    recordLinks[0] = {name: 'datetime'};
    recordLinks[1] = {name: 'sensorName'};
    recordLinks[2] = {name: 'period0'};
    recordLinks[3] = {name: 'destoreDate'};
    recordLinks[4] = {name: 'destoreReason'};
    recordLinks[5] = {name: 'destoreYVal'};
    recordLinks[6] = {name: 'alarmDate'};
    recordLinks[7] = {name: 'alarmName'};
    recordLinks[8] = {name: 'alarmYVal'};
    var fields = new Array(9);
    fields[0] = 'datetime';
    fields[1] = 'sensorName';
    fields[2] =  'period0';
    fields[3] = 'destoreDate';
    fields[4] =  'destoreReason';
    fields[5] = 'destoreYVal';
    fields[6] = 'alarmDate';
    fields[7] = 'alarmName';
    fields[8] = 'alarmYVal';
    var rec = new;
    var reader = new{}, rec);
    var store = new{
    			fields: fields,
    			reader: reader,
    			data  : data
    Here is en example of an element of my data array:
    {"datetime": '24/11/2012 10:45:42', "sensorName":'TEST 1',"period0": 22.80,"destoreDate":'24/11/2012 10:47:38',"destoreReason":'Checking',"destoreYVal":30.0,"alarmDate":undefined,"alarmName":undefined,"alarmYVal":undefined}
    My problem happens when initializing my variable "rec". I get this exception:
    TypeError: Object [object Object] has no method 'substring'
    Thanks to debug breakpoints, I determined that it happens in the ext-all-debug script , function parseNamespace line 4493 :
    if (name === from || name.substring(0, from.length) === from) {

    I tried to set my variable with simple String and it failed too (ex: recordLinks[0] = 'datetime';)

    Does anyone know why it does not work?


  2. There are many things wrong with the code. Could be simplified down to:

    var store = new{
        fields: ['name'],
        data  : [
            {name: 'datetime'},
            {name: 'sensorName'},
            {name: 'period0'},
            {name: 'destoreDate'},
            {name: 'destoreReason'},
            {name: 'destoreYVal'},
            {name: 'alarmDate'},
            {name: 'alarmName'},
            {name: 'alarmYVal'}

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts