Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: [2.1] Splash screen is white on startup on Android and iOS

    You found a bug! We've classified it as TOUCH-3915 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #11
    Sencha User
    Join Date
    Jul 2012
    Posts
    177
    Vote Rating
    9
      0  

    Default

    Anyoine able to repro this white screen on startup ?

  2. #12
    Sencha User
    Join Date
    Aug 2008
    Posts
    7
    Vote Rating
    1
      0  

    Default You're not alone

    @huberte I'm struggeling for days on the exact same problem.

    I started from the very default sencha cmd application ("sencha generate app TestApp ../tst")

    On safari or chrome: the application, built with "sencha app build package", is behaving correctly : the "waiting dots" on blue background are shown imediately and then the app is starting.

    On the device, built with "sencha app build native" and then copied on the device using iTunes: the loading image is shown for a very short time (say 250msec) then, where I was expecting to see the same "waiting dots" on a blue background, I see a white screen for about 1-2 secs and finally my app is starting.

    What is wrong? Why don't we see the waiting stuff before the Sencha application is started?

  3. #13
    Sencha Premium User
    Join Date
    Feb 2012
    Location
    Berne, Switzerland
    Posts
    723
    Vote Rating
    46
      0  

  4. #14
    Sencha User
    Join Date
    Jul 2012
    Posts
    177
    Vote Rating
    9
      0  

    Default

    Thanks ingo, but I think it's the thread for white screen of death, which I red. It seems that the app does not strat at all. here, the app is starting but there is no splash screen.

    it's very easy to repro though...

  5. #15
    Sencha User
    Join Date
    Aug 2008
    Posts
    7
    Vote Rating
    1
      0  

    Default

    @ingo.hefti thanks but the application is just running fine! No death here, only a (unacceptable) 1-2 second delay between the moment the "loading" image is hidden and the moment the application is actually starting. During that time, I was excepting the background to be blue with flashing dots but it remains white for 1-2 seconds and then the application is started properly.

    It's indeed so easy to reproduce: just build the default Sencha native app, drag and drop to iTunes and synchronise to install the app on your iDevice.

    Btw @huberte what device & iOS version are you testing on? Was also curious if you managed to run the app in the simulator and observed the same annoyance ?

  6. #16
    Sencha - Documentation Team
    Join Date
    Mar 2012
    Location
    Lawrence, KS
    Posts
    412
    Vote Rating
    79
      0  

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

  7. #17
    Sencha User
    Join Date
    Jul 2012
    Posts
    177
    Vote Rating
    9
      0  

    Default

    Btw @huberte what device & iOS version are you testing on? Was also curious if you managed to run the app in the simulator and observed the same annoyance ?
    Sorry gfrenoy, didn't see your question

    with all devices (ios, android and their respective simulator)

    And thanks greg, for the open ticket

  8. #18
    Sencha User
    Join Date
    Aug 2008
    Posts
    7
    Vote Rating
    1
      1  

    Default

    Glad to read this is classified as an official "bug". Thanks for that.

    Any idea of the priority of this bug?

    I mean: for me it is critical to have correct startup screen for my native app. This white screen in between the loading image and the actual app will not be accepted by any of my customers so I'm stuck with Sencha Touch today.

    Do other users and the Sencha team share this point view ?

    Thanks for your help.

  9. #19
    Sencha User
    Join Date
    Feb 2013
    Posts
    1
    Vote Rating
    0
      0  

    Default

    any status on this splash screen issue?

    We are about to demo the POC and this is annoying. Not sure why its got less priority?

  10. #20
    Sencha User
    Join Date
    Jul 2012
    Posts
    177
    Vote Rating
    9
      0  

    Default

    Sorry but I do not see the fix here :

    http://cdn.sencha.com/touch/sencha-t...ase-notes.html

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •