Results 1 to 10 of 16

Thread: Issue With Sencha CMD for generating images

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Sencha Premium Member
    Join Date
    Jan 2012
    Posts
    35
    Vote Rating
    1
      0  

    Default Issue With Sencha CMD for generating images

    Hi,
    I have created an custom UI component similar to below
    @include extjs-button-ui(
    'primarytab-toolbar-medium',
    $background-color:#444444,
    $background-color-over:#555555,
    $background-gradient:color-stops(#333333, #262626 5%, #1A1A1A 100%),
    $background-gradient-over: color-stops(#494949 0%,#303030 100%),
    $color:#CCCCCC,
    $color-over:#FFF,
    $color-disabled:#CCCCCC,
    $font-weight:bold,
    $font-family: $font-family,
    $font-family-over: $font-family
    );


    I generated CSS using the sencha cmd which looks fine. Now I need to create images for supporting IE 8.
    I added an entry in the custom.js as below
    {
    xtype: 'widget.button',
    ui: 'primarytab-toolbar-medium'
    }


    Ideally an image with name as 'btn-primarytab-toolbar-medium-bg.gif' should be generated. But the images generated is btn-primarytab-toolbar-medium-medium-bg.gif . Also the image generated is not having proper gradient.

  2. #2
    Sencha Premium Member
    Join Date
    Jan 2012
    Posts
    35
    Vote Rating
    1
      0  

    Default

    Can someone please reply to this thread.

  3. #3
    Ext JS Premium Member cmeans's Avatar
    Join Date
    Jun 2010
    Location
    Chicago, IL USA
    Posts
    117
    Vote Rating
    7
      0  

    Default

    I'm having the same problem. The gradient image being generated isn't using the right colors etc.. Though the file names appear to be correct.

  4. #4
    Sencha User dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,742
    Vote Rating
    258
      0  

    Default

    First thing to check is the rendering of theme.html in Chrome. Does the ui you have created appear correctly there?
    Don Griffin

    "Use the source, Luke!"

  5. #5
    Ext JS Premium Member cmeans's Avatar
    Join Date
    Jun 2010
    Location
    Chicago, IL USA
    Posts
    117
    Vote Rating
    7
      0  

    Default

    I've check Chrome, IE & FF, not rendering correctly in theme.html.

  6. #6
    Sencha User dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,742
    Vote Rating
    258
      0  

    Default

    The theme.html file need only render properly in Chrome/WebKit as Cmd uses that rendering engine to do the image slicing.

    I would first figure out what is causing the rendering of theme.html to be incorrect in Chrome. Once that is working, slicing should work.
    Don Griffin

    "Use the source, Luke!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •