Results 1 to 7 of 7

Thread: Crashes when loading Resource

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Ext JS Premium Member
    Join Date
    Apr 2008
    Location
    Austin, TX
    Posts
    18
    Vote Rating
    0
      0  

    Default Crashes when loading Resource

    REQUIRED INFORMATION


    Architect Build tested:
    • Build: 678


    Project Type:
    • ExtJS 4.x (Did not test a Touch project)


    Description:
    I have a fairly large number of JS and CSS files to include by hand in Resources. Several times now I have started typing the path for a file, but I often forget the complete file path. For example, I tend to forget if the path is resources/to/theme/file.css or resources/to/themes. I often switch (using alt+tab) to another program where I can find the full path to the new file. When I switch, the path entered in the url field (of the resource I'm creating) is incomplete. In my case, it is often part of the relative path with no file (yet). When I do this, it appears like Architect is attempting to read the file, then it throws an exception notice and crashes.

    Steps to reproduce the problem:
    • Add a new CSS or JS Resource
    • Start typing a path in the URL field but don't complete it.
    • Switch to any other program


    The result that was expected:
    • Nothing


    The result that occurs instead:
    • Crashes


    HELPFUL INFORMATION


    Screenshot, Project, or Video:
    • not provided


    Possible fix:
    • not provided


    Operating System:
    • Win 8 Pro 64-bit

  2. #2
    Sencha Premium Member
    Join Date
    Jan 2013
    Posts
    25
    Vote Rating
    3
      0  

    Default

    I've encountered this problem also when I tried to add a existing css file under my project's resource folder to Architect. If I add a new css file, give it a id and url, and then save it, it won't crash.

  3. #3
    Touch Premium Member BostonMerlin's Avatar
    Join Date
    Aug 2010
    Location
    Boston
    Posts
    548
    Vote Rating
    44
      0  

    Default

    hit the same problem as the OP.

    John

  4. #4
    Sencha User Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,953
    Vote Rating
    65
      0  

    Default

    Looking into this.

    No crash on OS X. Booting up my Windows machine...

    I'll get back w/ more info soon.

    Also I'm considering adding a feature that if you drop files into a local directory named resources Architect will pick them up and add them as resources to the project. Does this sound like a good features?
    Phil Strong
    @philstrong

  5. #5
    Sencha User Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,953
    Vote Rating
    65
      0  

    Default

    I can't get it to crash Windows 7. John are you also Windows 8?
    Phil Strong
    @philstrong

  6. #6
    Sencha User Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,953
    Vote Rating
    65
      0  

    Default

    Also John can you reproduce this on Architect 2.2 (beta build)?
    Phil Strong
    @philstrong

  7. #7
    Touch Premium Member BostonMerlin's Avatar
    Join Date
    Aug 2010
    Location
    Boston
    Posts
    548
    Vote Rating
    44
      0  

    Default

    Nope, can't reproduce error in new 840 build on mac. Previous beta builds had this problem though.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •