Results 1 to 4 of 4

Thread: Cannot generate new Sencha app instance - "not recognized Sencha SDK folder"

  1. #1
    Sencha User
    Join Date
    Feb 2013
    Location
    West Coast, USA
    Posts
    3
    Vote Rating
    0
      0  

    Default Cannot generate new Sencha app instance - "not recognized Sencha SDK folder"

    In terminal I have cd/ into my SDK I downloaded (latest version) as well as I have installed the latest SDK Tools and latest Sencha Cmd versions using the default install location. Everytime I try to create or generate an app, I get the error:

    [ERROR] The current working directory (/FILEPATH) is not a valid SDK directory. Please 'cd' into a SDK directory before executing this command.

    (I replaced the file path, that is not really where terminal is pointed.)


    When I type the command while in the SDK directory:

    $ sencha


    I get the response:

    [WARN] The current working directory (/Users/alexa/Documents/Alexa-WEB/Clients/MAGNER SANBORN/Site-webTests/app-frameworks/Sencha/touch-2.1.1) is not a recognized Sencha SDK or application folder. Running in backwards compatible mode.

    Sencha Command v2.0.0 Beta 3
    Copyright (c) 2012 Sencha Inc.

    I have the latest 3.0 Cmd installed, so that's confusing already. I don't understand what the problem is, because I have tried various combinations of pointing my MAMP server to the SDK as well as interior folders, even the SDK tools application and Sencha Cmd installation. (I was desperate at that point lol)

    I am using a Mac, MAMP, and the latest versions of the SDK, Tools and Cmd. I have tried the following commands:

    $ sencha generate app...
    $ sencha create app...
    $ sencha app create...


    Can anyone help? Thank you!


  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,556
    Answers
    3932
    Vote Rating
    1272
      0  

    Default

    If you are using Sencha Touch 2.1.0, you should use Sencha Cmd not SDK Tools
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  3. #3
    Sencha User
    Join Date
    Feb 2013
    Location
    West Coast, USA
    Posts
    3
    Vote Rating
    0
      0  

    Default

    Quote Originally Posted by mitchellsimoens View Post
    If you are using Sencha Touch 2.1.0, you should use Sencha Cmd not SDK Tools
    So I should uninstall the SDK tools 2.x that I have, point MAMP at my SDK I downloaded, and Cmd should work perfectly fine that way?

  4. #4
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,556
    Answers
    3932
    Vote Rating
    1272
      0  

    Default

    Yes
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •