Results 1 to 4 of 4

Thread: Button with custom ui property not injecting frame in IE7,8

  1. #1
    Ext JS Premium Member
    Join Date
    Aug 2010
    Posts
    52
    Vote Rating
    2
      0  

    Exclamation Button with custom ui property not injecting frame in IE7,8

    Hi Chaps,


    I am experiencing a strange problem in Ext Js 4.1.3, IE7,8.


    When I use a button with a custom ui property like:


    {
    xtype: 'button',
    ui: 'gray',
    locales: {
    text: 'rsm.index.graph.label.overview'
    },
    action: 'overview'
    }


    it won't apply the framing that happens in IE to inject sliced images tl, tc, tr


    if I remove the ui attr it does anyone experienced this before? even setting frame: true wont' work.




    Cheers
    Florian

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,390
    Answers
    716
    Vote Rating
    498
      0  

    Default

    Are you using SDK or Sencha Cmd? .. version?

    Scott.

  3. #3
    Ext JS Premium Member
    Join Date
    Aug 2010
    Posts
    52
    Vote Rating
    2
      0  

    Default

    Hi Scott,

    sorry I missed your reply. I am using Sencha CMD. But this is not about the slicing. It's just about how the buttons is rendered. If I use a cls to define my style class it's fine. just when I use a custom ui property it wont render the framed button anymore.


    Cheers

    Florian

  4. #4
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,390
    Answers
    716
    Vote Rating
    498
      0  

    Default

    I just filed a bug report there tabpanel was not adhering to UI changes as well.

    This might be related. I will make a note in the report.

    Scott.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •