Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Which Cmd version for ExtJS 4.2.0

  1. #1
    Sencha Premium Member
    Join Date
    Oct 2010
    Posts
    94
    Vote Rating
    9
      1  

    Default Which Cmd version for ExtJS 4.2.0

    So which version of Sencha Cmd is recommended for newly released ExtJS 4.2.0? 3.0.2 or 3.1.0 Beta?

  2. #2
    Sencha User
    Join Date
    Aug 2012
    Location
    France
    Posts
    43
    Vote Rating
    31
      0  

    Default

    Sencha Cmd v3.0.2.288 is not working, (i've try an upgrade on one of my app and get an error)

    So if it's not him maybe 3.1 !

    Code:
    [ERR]           com.sencha.exceptions.ExScript: Wrapped com.sencha.exceptions.ExState: Failed to determine framework name.  Please ensure this command was issued from either a framework or application directory (x-app-upgrade#151)
       runAppUpgrade (x-app-upgrade:151)
       [anonymous] (x-app-upgrade:162)
       x_app_upgrade (x-app-upgrade:160)
       <script> (anonymous:1)

  3. #3
    Sencha User
    Join Date
    Feb 2011
    Location
    Moscow, Russia
    Posts
    18
    Vote Rating
    0
      0  

    Default

    cmd/sencha.cfg file says:
    ---
    #Mon, 11 Mar 2013 22:56:23 -0700
    # This is the SDK version. By defining this property, we are declaring this
    # folder to be an SDK distribution.
    framework.name=ext
    framework.version=4.2.0.663
    framework.classpath=${framework.dir}/src

    #------------------------------------------------------

    # This is the minimum required Sencha Command version:
    framework.cmd.minver=3.1.0.206

    # This is the current version of the Sencha Command at the time of this SDK release:
    framework.cmd.version=3.1.0.216
    ---

    So it looks like this 4.20 release needs at least Cmd 3.1.0.206 .
    The funniest thing is that the lastest Cmd link I could find (in Sencha Touch 2.2 beta forum) is 3.1.0.192 RC.

  4. #4
    Sencha User
    Join Date
    Aug 2012
    Location
    France
    Posts
    43
    Vote Rating
    31
      0  

    Default

    Oh! i've download 3.1.0.130 ...

    So i'll wait the last sencha cmd release before testing Ext 4.2.0 ...

  5. #5
    Sencha User
    Join Date
    Nov 2011
    Posts
    21
    Vote Rating
    5
      1  

    Default

    I hope this is addressed soon. It makes it hard to work with ExtJS 4.2.0 release when you can't upgrade your apps to it.

  6. #6
    Ext JS Premium Member
    Join Date
    Sep 2011
    Posts
    62
    Vote Rating
    0
      0  

    Exclamation when will Sencha Cmd 3.1.0.216 be released?

    We are also wondering when the newest version of Sencha Cmd will be released. It doesn't seem as if anything compiles in 4.2.0 without it. We are dead in the water in regards to generating themes.

  7. #7
    Sencha Premium Member boblestat's Avatar
    Join Date
    May 2012
    Posts
    2
    Vote Rating
    0
      0  

    Default

    yeah version 3.1.0.130 doesn't work....

  8. #8
    Sencha User
    Join Date
    Dec 2011
    Posts
    17
    Vote Rating
    -1
      1  

    Default

    Also the guides in the 4.2 docs needs an update to reflect the new theming possibilities. New users could be frustated on relying on the older theming guides.

  9. #9
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    646
    Vote Rating
    40
      0  

    Default

    Sencha Cmd v3.1.0.216 is "released" on the support.sencha.com now
    Sven Tore Iversen

  10. #10
    Sencha User
    Join Date
    Dec 2011
    Posts
    17
    Vote Rating
    -1
      0  

    Default

    What about GPL Users?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •