Results 1 to 3 of 3

Thread: quick tip stuck after mousing off of tree panel

  1. #1
    Sencha User
    Join Date
    Mar 2010
    Vote Rating

    Default quick tip stuck after mousing off of tree panel

    I have basic qtips defined on node interfaces for a tree panel. If I hover over tree panel items, the qtips pop up just fine. If I move the mouse off of the tree panel onto another part of the page, the qtip follows the mouse. The interesting thing is the qtip that gets stuck to the mouse is always taken from the last qtip in the tree.

    Mousing over another major component makes the stuck qtip disappear, I'm assuming because of a reevaluation by the QuickTipManager.

    This did not appear to happen in 4.0.7 or 4.1.3.

    • The TreePanel's containermouseout event doesn't trigger like I was hoping so I guess I'll start another thread on that.
    • I tried creating a hidden node interface with no qtip. That works, but I can't completely hide that dummy node.
    • I tried playing with the QuickTipManager configuration. That can help, but that has side effects for any other qtip in the interface.

  2. #2
    Sencha User Animal's Avatar
    Join Date
    Mar 2007
    Vote Rating


    I can't repro this.

    Running the following in a page which has the tree classes present works:

    new Ext.tree.Panel({
        title: 'Node has qtip',
        renderTo: document.body,
        store: {
            root: {
                text: 'foo',
                qtip: 'Bar'
        height: 300,
        width: 200
    Hovering over the node shows a tooltip containing "Bar".

    Moving off the node hides it.

    Can you show a simple testcase like this exhibiting the bug?

  3. #3
    Sencha Premium Member cmendez21's Avatar
    Join Date
    Jun 2007
    Mexico D.F.
    Vote Rating

    Default Tooltip issues on components using (table view)

    Hi there , i recently had a similar issue with this on version
    how i got the issue :

    I have a border layout (west) a tree panel and TAB PANEL (center)
    on the tree side i load data (php) with something like modules access (sort of a menu) so when i access a module making double click i create a new GRID (MVC view on a new tab) per module.

    The problem is when i create the new GRID /tab all the rows in the grid have the Tooltip of the last node on the TREE. checking src/tree/view.js i found this :

                    rowValues.rowAttr = {};
                    // We always need to set the qtip/qtitle, because they may have been
                    // emptied, which means we still need to flush that change to the DOM
                    // so the old values are overwritten
                    rowValues.rowAttr['data-qtip'] = record.get('qtip') || '';
                    rowValues.rowAttr['data-qtitle'] = record.get('qtitle') || '';
    the problem is that the GRID when checking (firebug & illuminations) i found that on the GRID VIEW->rowTpl->rowValues

    rowValues.rowAttr['data-qtip'] and rowValues.rowAttr['data-qtitle'] still exists on the GRID view and both have the last value (same as the last node tooltip). Somehow the Ext.view.Table is being used as a singleton on the tree side (code) so new grids gets the repercussions of this.

    So as for the moment the workaround for me to work was to alter
    Ext.grid.View in src :
    initComponent: function() {
        var me=this; 
            itemClasses: [],
            rowClasses: []
    So with this way the view for the grid initializes correctly and the tooltip is no more stuck (the same tooltip of the last tree node)

    perhaps other components using view->table had the same effect , at the moment havent checked on the night builds to see if the problem is fixed.
    E2CS: Extjs - Event calendar solution | XtPrinter
    Calendar Thread | XtPrinter Thread| Blog

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts