I've got the fun task of converting our projects entire UI from 2.2.5 to 3.0.1. Well I didn't want to have the situation where you modify 100 ui's and eclipse crashes and you lose it all. So I began by converting one UI at a time and leaving the rest at 2.2.5 and seeing if I could run them in the same project without issue. Locally worked fine, tested dev mode and made sure the maven build succeeded.

After confirming that both modes work and the converted UI worked as expected I committed my changes to SVN then started the next UI.

Well I was about 8 UI's in when a co-worker updated to the recent changes. He was first having issues running maven builds getting an out of memory error and it failed on the same class from the gxt 3 blue theme. After upping his heap size we were able to get him passed that.

Then theirs dev mode. He can not run in dev mode at all. We see in the dev mode console :


Then as a result of that error the ui thread throws a null pointer exception.

The big question is why is this happening. I have now checked everything in besides personal settings like my properties file which only has my local db properties in it. He is completely up to date with me. So in comparing what he has vs. what I have we see absolutely no difference. Yet I'm able to run and he is not.

We now have 2 developers dead in the water and I mine as well be dead in the water because now I've stopped working to help fix their situation. We have been trying to find a fix for a full day now and I thought it would be good to get other ideas/suggestions.

Any help would be appreciated, thank you.