Results 1 to 2 of 2

Thread: URL Prefix setting not taking effect until restart

    Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-3545 in a recent build.
  1. #1
    Sencha Premium Member
    Join Date
    Dec 2011
    Vote Rating

    Default URL Prefix setting not taking effect until restart

    Architect Build tested:
    • Build: 678
    Project Type:
    • Touch 2.1
    • I change the URL Prefix in settings and it does not take effect in the current session.
    Steps to reproduce the problem:
    • Create a Touch 2.1 project
    • Add a model with an Ajax Proxy {url:'somedata.json' and a JSON reader
    • Add a store that uses said model.
    • Set the URL Prefix in settings to local server on say port 8000 that is serving the app.html and somedata.json
    • Verify in architect that the store data loads.
    • Change the URL Prefix setting to a non-served port, say 8888
    • Load the store data again.
    The result that was expected:
    • An error indicating problem loading data.
    The result that occurs instead:
    • Data can still be loaded even though there is no server at URL prefix
    • Load data error does happen when Architect is closed and restarted.

    Possible fix:
    • Make the "Save" button from Settings refresh the Architect config in the running session not just the xds.
    Operating System:
    • Windows 7 Pro
    Also it would be great if the URL Prefix setting was kept in the .architect profile instead of the project xds so collaborators can run servers where they please.

  2. #2
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Vote Rating


    Thanks for the bug report, we will look into it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts