Results 1 to 4 of 4

Thread: Include Ext.chart Cmd v3.1.1.274

  1. #1
    Sencha Premium Member
    Join Date
    Jan 2013
    Location
    Germany Krombach
    Posts
    5

    Default Include Ext.chart Cmd v3.1.1.274

    Hi,

    I use Ext.chart in my project.
    During developement everything works fine, but when I build it with "sencha app build" it seems that the charts are not included. In the console I see that he tries to load the file
    PHP Code:
    "Uncaught Error: [Ext.Loader] Failed loading synchronously via XHR: 'http://xxx/build/Portal/testing/src/chart/Chart.js'; please verify that the file exists. XHR status code: 404 " 
    When I use require, no matter how like in the app.js:
    PHP Code:
    //@require Ext.chart.Chart
    //@require Ext.chart.axis.Axis
    //@require Ext.chart.axis.Numeric
    //@require Ext.chart.axis.Time
    //@require Ext.chart.series.Line 
    or in the files like app.js or my panel which holds the Chart:
    PHP Code:
    require: ['Ext.chart.Chart'..... 
    I get following error in the console, only in the build file.
    PHP Code:
    Uncaught TypeErrorCannot read property 'prototype' of undefined all-classes.js:5965 
    In the Version 3.0.x everything worked. What am I doing wrong, i didnt find out a proper way to inclu

  2. #2
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,450

    Default

    This for Ext JS or Sencha Touch?
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Fullstack Engineer
    ________________
    Modus Create is based on the model of an open source team. We’re a remote, global team of experts in our field. To find out more about the work we do, head over to our website.

    Check out my GitHub:
    https://github.com/mitchellsimoens

  3. #3
    Sencha Premium Member
    Join Date
    Jan 2013
    Location
    Germany Krombach
    Posts
    5

    Default

    Ohh sorry about that.
    ExtJs 4.1.1.a

  4. #4
    Sencha Premium Member
    Join Date
    Jan 2013
    Location
    Germany Krombach
    Posts
    5

    Default

    I upgraded to ExtJs 4.2.0 now it works perfect.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •