Results 1 to 2 of 2

Thread: Bug on changing inputType on a textbox

    Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Sencha Premium Member
    Join Date
    Nov 2012
    Vote Rating

    Default Bug on changing inputType on a textbox


    Architect Build tested:
    • Build: 951
    Project Type:
    • ExtJS 4.x
    • Upon changing an Ext.form.field.text componentto a Ext.form.field.number when using the config panel and changing the component type under inputType The config panel does not change to reflect the change in type, it remains as a Ext.form.field.text. The component does change within the Design window (although does not look identical to a Ext.form.field.number component)
    Steps to reproduce the problem:
    • Create a new project in Sencha Architect 2.2
    • Add a new panel to a view
    • Select a text field component and add it to the view
    • change input type from config panel to Number type
    • Config options does not update
    The result that was expected:
    • Component changes from Ext.form.field.text to Ext.form.field.number then config panel updates to reflect change.
    The result that occurs instead:
    • Component changes from Ext.form.field.text to Ext.form.field.number then config panel remains as Ext.form.field.text and does not allow for changing of other components property's easily.

    Screenshot, Project, or Video:
    • attached project file, new project, two panels added to view (form type and panel type) each initially had a textfield added and changed using the config to a number type. config panel does not display number properties.
    Possible fix:
    • Unknown
    Operating System:
    • Windows 7 x64
    Attached Files Attached Files

  2. #2
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Vote Rating


    inputType is a configuration that will change the actual dom input type. It does not change the type of class you are using.

    You are looking to transform your existing text field to a number field. Right click on it, go to the transform menu and then click Number.
    Aaron Conran

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts