Results 1 to 4 of 4

Thread: Failed to download remote catalog

  1. #1
    Sencha Premium Member christoph.hartmann's Avatar
    Join Date
    Feb 2013
    Bonn, Germany

    Default Failed to download remote catalog


    I get this error message when building my Ext JS app

    Failed to download remote catalog : Error downloading

    For security reasons there is no internet on my developer machine. Can you suggest how to disable this catalog access or where to place it such that the build can run offline?

  2. #2
    Sencha Premium Member
    Join Date
    Apr 2009


    I'm in a similar situation. I can manually download the file and if there is some way to configure Sencha Cmd to use a proxy it might also work. What is the downside of having this portion of the action fail?


  3. #3



    We're having this exact problem with Sencha Cmd 3.1.1 building a Sencha Touch 2.2 app, but we have Internet access on our build server, it's just that sometimes it fails which causes the build to fail, which is REALLY annoying.

    It seems like it's always the first build of the day that fails and everything is fine after that.

  4. #4
    Sencha Premium User
    Join Date
    Nov 2013
    Piacenza, Italy


    Sencha Cmd still has the same problem.

    You can see the repository with this command:
    sencha package repo list
    Here is another thread on the argument:

    Quote Originally Posted by mitchellsimoens View Post
    2) This functionality is baked into Cmd and there isn't any property to simply turn this off. In theory, if you checked in the packages that is required and such it shouldn't try to download the catalog of packages. That being said, you can try to turn off the package system via this command:

    sencha pacakge repo remove sencha
    however doing this will mean that you won't ever have access to the remote package functionality anymore.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts