I'm following the instructions for using the CMD slice command discussed here:


Everything has worked fine up until I try to use the actual slice command. The blog post says to use the command:

sencha slice theme -d . -c resources/css/ext-all-green.css -o resources/themes/images/green -v
First problem I ran into was that the command order should have been:

sencha theme slice ....
But once I reordered the command to the following:

sencha theme slice -d . -c resources/css/ext-all-green.css -o resources/themes/images/green -v
I get an error that reads:
Sencha Cmd v3.1.1.274
[ERR] java.lang.NullPointerException
There's no other details as to what this means.

I tried to break down the problem by looking at each part of the command:
  • sencha theme slice // the command to be run
  • -d . // The directory to run it from (assuming, there's no -d listed in the options when running "sencha HELP theme slice")
  • -c resources/css/ext-all-green.css // not sure what the c flag would stand for (also not listed in the help information) but I'm assuming since it's a relative path to the css file we generated it's what's supposed to be telling the slice tool which css file to evaluate and generate the images from
  • -o resources/themes/images/green // the output directory to create the images in
  • -v // verbose mode?? It's also not listed in the help.
from the ext directory the relative paths are correct so the "-d ." makes sense. I've checked down both of the relative paths and the ext-all-green.css file was definitely generated when I compiled my sass file, and the duplicate of the default images folder that I created and renamed as 'green' definitely exists.

Could someone help explain what I'm doing wrong? I've been trying like crazy to get a custom button ui created for the rsvp system on my wedding website and have been hitting a wall at every step. Any help would be greatly appreciated. Hell if I can get past this and get the custom button ui created I'll invite you to the wedding!