Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Apple Store Upload fails with "Non-public API" usage error

  1. #11
    Sencha User
    Join Date
    May 2012
    Location
    Colombia
    Posts
    46

    Default

    waited a lot. Solved with phonegap.

  2. #12

    Default Waiting

    A also waiting near week this issue fixing. This is very important issue.

  3. #13
    Sencha User
    Join Date
    Jul 2011
    Posts
    30

    Default

    I'm experiencing the same issue - Sencha Touch 2.1.1 and Sencha CMD 3.1.1.274.

    Looking for a solution.

    Regards,

    Darryl

    UPDATE: From Premium Support

    The 2.2.1 release (more the Cmd 3.1.2 release which will get released at same time) is fixing the UDID issue which admittedly is a pretty big one. We are in final steps of QA on these releases.

  4. #14
    Sencha Premium Member
    Join Date
    Sep 2012
    Posts
    13

    Default

    Sencha CMD 3.1.2.342 fixed the problem with my Touch 2.1 based application.

    When I tried to upgrade the same app to Touch 2.2 it would work fine in the browser but never got passed the app loading indicator on the iPad.

  5. #15
    Sencha User
    Join Date
    Jul 2012
    Posts
    177

    Default

    I need a 3.0.2.288 with this issue fixed !

    Is it possible ?

    the latest sencha produces to buggy package for me !

    EDIT : tried again and again with 3.1.2.342, ended with the same error :
    Code:
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/httpcl
    ient-4.2.1.jar!/
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/common
    s-logging-1.1.1.jar!/
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/common
    s-codec-1.6.jar!/
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/httpcl
    ient-cache-4.2.1.jar!/
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/httpco
    re-4.2.1.jar!/
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/httpmi
    me-4.2.1.jar!/
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/slf4j-
    api-1.6.6.jar!/
    [DBG] Add extension classpath entry 'sencha-io' : jar:file:/C:/apps/Sencha/Cmd/3.1.2.342/extensions/sencha-io/lib/gson-2
    .2.1.jar!/
    [DBG] using path C:\apps\Sencha\Cmd\3.1.2.342\stbuild;C:\apps\Sencha\Cmd\3.1.2.342\stbuild\bin;C:\apps\Sencha\Cmd\3.1.2.
    342;C:\dev\java;C:\Windows\system32;C:\Windows;C:\apps\java\jdk1.6.0_45\bin;C:\Program Files\Satsuki Decoder Pack\Filtre
    s;C:\Program Files (x86)\OpenVPN\bin
    [DBG] executable located at C:\apps\Sencha\Cmd\3.1.2.342\stbuild\stbuild.exe
    [DBG] using working directory .
    [DBG] exit code was : -1073741819
    [DBG] exit code was : -1073741819
    itunes connect says it's not codesigned

  6. #16

    Default How we fixed it

    We had the same problem using Sencha Cmd 3.0.2.288 and a not up-to-date version of the Sencha SDK.

    Our Solution:
    - Upgrade Sencha CMD to the latest version (today this is: 3.1.2.342)
    - Upgrade the SDK to the latest version using the command: `sencha app upgrade -noframework`

    Hope you are successful with it...
    Last edited by [email protected]; 13 Jun 2013 at 6:26 AM. Reason: version was wrong

  7. #17

  8. #18

    Default

    Yep. The codesign was sucessfully done through sencha cmd / the stbuild executable.

    `sencha -d app build native build/production_distribution`

    returns the following output at the end:
    ...
    The application was successfully packaged
    The application was successfuly signed
    ..


    And with `codesign --display --verbose=4 ./path/to/our.app` I get:

    Identifier=org.betterplace.mobileplatform
    Format=bundle with Mach-O thin (armv7)
    ...
    Authority=iPhone Distribution: gut.org gemeinnutzige Aktiengesellschaft
    Authority=Apple Worldwide Developer Relations Certification Authority
    Authority=Apple Root CA
    Signed Time=14.06.2013 10:41:46
    Info.plist entries=28
    Sealed Resources rules=4 files=142
    Internal requirements count=1 size=212

    FYI: I am on Mac OS X (10.8) with an installed XCode. I am not sure how Sencha does the codesign since it is hidden inside the stbuild executable and wether they are using the native codesign utility or they reengineered the process to make it available on Windows/Linux.
    Last edited by [email protected]; 14 Jun 2013 at 1:14 AM. Reason: added some more info

  9. #19
    Sencha Premium Member
    Join Date
    Jul 2012
    Location
    Concord, NC
    Posts
    44

    Default

    If you want to stay on Sencha CMD 3.0.2.288 and Touch 2.1.1 then save yourself the trouble and use PhoneGap. I did the upgrade to CMD and I couldn't get native build OR PhoneGap to work. The app simply would not execute any longer. I wasted several days on this whole process, but now that I finally have PhoneGap working via my Mac it seems SO MUCH better.

    I develop on a Windows 7 machine using Sencha Architect. On Windows 7 run sencha app build package and move the files over to the www folder on the Mac PhoneGap project.

  10. #20
    Sencha User
    Join Date
    May 2012
    Location
    Colombia
    Posts
    46

    Default

    Thank you. I did with phonegap at that moment. Now they updated the sencha commands and everything returned to normal.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •