Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: architect build errors ruby

  1. #11

    Default Modify yor sencha.cgf file

    Hi, you can solve this problem modifying your sencha.cfg file. This file is located in yourAppRoot/.sencha/app/sencha.cfg.

    You must write at the last line: skip.ass=1

    After, build your app again.

    However, I don't know why is necesary install ruby to build sencha apps without modify the .cfg file.

    Regards

  2. #12
    Sencha User
    Join Date
    Jul 2010
    Posts
    12

    Default

    You need to add Ruby path (eg. c:\ruby\bin) to the PATH environment variable. Note: not PATH in User variables, but in System variables. See here: http://stackoverflow.com/questions/1...9024#20389024I believe this should be improved to be smarter.

  3. #13
    Sencha Premium User jvandemerwe's Avatar
    Join Date
    Apr 2009
    Location
    Raalte, Netherlands
    Posts
    260

    Default Same problem here too

    I am working with Windows 8.1 and I have the same problem. Even when I type: ruby -v from any directory it shows me that Ruby 1.93 is installed, but Sencha Architect is not finding it.

    My PATH is just OK and even a restart of the PC didn't help. Then it becomes quite little transparent where to find the error.

    It would better if your Ruby path was part of the Sencha Architect settings. And then also include a Ruby test in Architect. Not that you find out the trouble when building the app. And it should not be that Sencha Command latest version is supporting a different Ruby version then Sencha Architect. Sencha CMD 4.0.1.45 is supporting Ruby 2.0 and Sencha Architect 3 is not. That is not very helpful either.

  4. #14
    Sencha User
    Join Date
    May 2014
    Location
    Passo Fundo, Brazil
    Posts
    6

    Default Problem solved.

    Quote Originally Posted by marsking View Post
    You need to add Ruby path (eg. c:\ruby\bin) to the PATH environment variable. Note: not PATH in User variables, but in System variables. See here: http://stackoverflow.com/questions/1...9024#20389024I believe this should be improved to be smarter.
    I had the same issue on Windows 8.1 and this solved my problem.

    Thank you!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •