Results 1 to 2 of 2

Thread: Why cmd loads classpath from its own temporary file

  1. #1
    Sencha User
    Join Date
    Nov 2008
    Vote Rating

    Default Why cmd loads classpath from its own temporary file

    My app root is C:\Program Files\Zend\Apache2\htdocs\artcom-desktop\client, I run from this location the command:

    sencha -sdk-path="C:\Program Files\Zend\Apache2\htdocs\ext4" compile -classpath=app\testext\js\loading,app\testext\js\loading\TestLoading.js page -in=markup.html -out=app\testext\js\loading\build\markup.html

    Ext.application has its appFolder property to "app/testext/js/loading" and is defined in file named TestLoading.js.

    Why the compiler loads:
    Loading classpath entry C:\Program Files\Zend\Apache2\htdocs\artcom-desktop\client\sencha-compile-temp-dir\ebd679c7-63b0-47d6-bdc4-05048caa8261
    and ends up with:
    [ERR] Failed to find file(s) for depdency reference C:\Program Files\Zend\Apache2\htdocs\artcom-desktop\client\sencha-compile-temp-dir\

    It seems like it is trying to treat application file as another directory with classes ...

    I'm using v3.1.0.256

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Gainesville, FL
    Vote Rating


    Have you tried with the latest public release?
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    Learn BBCode and use it!

    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2

    Think my support is good? Get more personalized support via a support subscription.

    Need more help with your app? Hire Sencha Services

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts